summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-10-20 01:22:57 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-10-20 01:22:57 +0000
commit508998c568d90653ec1019be4b4b27b9ba6a6330 (patch)
tree970320b1d73b72e3f913c451efc837042eb57443 /dev-libs/maloc/maloc-0.1.2.ebuild
parentMasking upcoming packages "dev-libs/maloc" and "sci-chemistry/apbs". (diff)
downloadgentoo-2-508998c568d90653ec1019be4b4b27b9ba6a6330.tar.gz
gentoo-2-508998c568d90653ec1019be4b4b27b9ba6a6330.tar.bz2
gentoo-2-508998c568d90653ec1019be4b4b27b9ba6a6330.zip
Initial import
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'dev-libs/maloc/maloc-0.1.2.ebuild')
-rw-r--r--dev-libs/maloc/maloc-0.1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/maloc/maloc-0.1.2.ebuild b/dev-libs/maloc/maloc-0.1.2.ebuild
new file mode 100644
index 000000000000..86fb9c8fcc05
--- /dev/null
+++ b/dev-libs/maloc/maloc-0.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-0.1.2.ebuild,v 1.1 2005/10/20 01:20:05 ribosome Exp $
+
+inherit eutils
+
+MY_PV="0.1-2"
+
+DESCRIPTION="MALOC is a small, portable, abstract C environment library for object-oriented C programming"
+LICENSE="GPL-2"
+HOMEPAGE="http://scicomp.ucsd.edu/~mholst/codes/maloc/index.html#overview"
+SRC_URI=" http://cam.ucsd.edu/~mholst/codes/${PN}/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/readline"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ # do not build blas
+ local myconf="--disable-blas"
+
+ # configure
+ econf ${myconf} || die "configure failed"
+
+ # fix install location of libs in Makefile
+ sed -e "s|libdir = \${prefix}/lib/\${fetk_cpu_vendor_os}|libdir = \${prefix}/lib/|" \
+ -i src/aaa_lib/Makefile || \
+ die "failed to patch lib Makefile"
+
+ # build
+ make || die "make failed"
+}
+
+src_install() {
+
+ # install libs and headers
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install doc
+ dohtml doc/index.html || die "failed to install html docs"
+}