summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-01-14 06:48:11 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-01-14 06:48:11 +0000
commitd9a6791581be5cd08fc40329e16bc2d66727ceb4 (patch)
treee524eea721d8cc86a0a71351b51770701b1c01e2 /dev-libs/log4cpp
parentThe broken sse2 detection code is gone, so skip this patch unconditionally fo... (diff)
downloadgentoo-2-d9a6791581be5cd08fc40329e16bc2d66727ceb4.tar.gz
gentoo-2-d9a6791581be5cd08fc40329e16bc2d66727ceb4.tar.bz2
gentoo-2-d9a6791581be5cd08fc40329e16bc2d66727ceb4.zip
Version bump, wrt bug #454712. Migrate to autotools-multilib eclass, build tests only when they are requested, build static lib conditionally. Fix building with Automake 1.13, wrt bug #467666
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/log4cpp')
-rw-r--r--dev-libs/log4cpp/ChangeLog12
-rw-r--r--dev-libs/log4cpp/files/log4cpp-1.1-automake-1.13.patch11
-rw-r--r--dev-libs/log4cpp/files/log4cpp-1.1-cmath-fix.patch10
-rw-r--r--dev-libs/log4cpp/log4cpp-1.1.ebuild56
4 files changed, 87 insertions, 2 deletions
diff --git a/dev-libs/log4cpp/ChangeLog b/dev-libs/log4cpp/ChangeLog
index b1c3caf951f9..fdd5759b3dfc 100644
--- a/dev-libs/log4cpp/ChangeLog
+++ b/dev-libs/log4cpp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/log4cpp
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/ChangeLog,v 1.20 2014/08/10 20:38:10 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/ChangeLog,v 1.21 2015/01/14 06:48:11 pinkbyte Exp $
+
+*log4cpp-1.1 (14 Jan 2015)
+
+ 14 Jan 2015; Sergey Popov <pinkbyte@gentoo.org> +log4cpp-1.1.ebuild,
+ +files/log4cpp-1.1-automake-1.13.patch, +files/log4cpp-1.1-cmath-fix.patch:
+ Version bump, wrt bug #454712. Migrate to autotools-multilib eclass, build
+ tests only when they are requested, build static lib conditionally. Fix
+ building with Automake 1.13, wrt bug #467666
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> log4cpp-1.0.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-libs/log4cpp/files/log4cpp-1.1-automake-1.13.patch b/dev-libs/log4cpp/files/log4cpp-1.1-automake-1.13.patch
new file mode 100644
index 000000000000..ffac4a1dbfc7
--- /dev/null
+++ b/dev-libs/log4cpp/files/log4cpp-1.1-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2015-01-14 09:37:13.616446476 +0300
++++ configure.ac 2015-01-14 09:37:26.119445770 +0300
+@@ -17,7 +17,7 @@
+
+ #AC_CONFIG_SRCDIR(configure.in)
+ AC_CONFIG_AUX_DIR(config)
+-AM_CONFIG_HEADER(include/config.h)
++AC_CONFIG_HEADERS([include/config.h])
+
+ AM_INIT_AUTOMAKE
+
diff --git a/dev-libs/log4cpp/files/log4cpp-1.1-cmath-fix.patch b/dev-libs/log4cpp/files/log4cpp-1.1-cmath-fix.patch
new file mode 100644
index 000000000000..fe3c810814bd
--- /dev/null
+++ b/dev-libs/log4cpp/files/log4cpp-1.1-cmath-fix.patch
@@ -0,0 +1,10 @@
+--- src/PatternLayout.cpp.orig 2015-01-14 09:24:32.332489499 +0300
++++ src/PatternLayout.cpp 2015-01-14 09:23:18.162493691 +0300
+@@ -24,6 +24,7 @@
+ #include <iomanip>
+ #include <ctime>
+ #include <cstdlib>
++#include <cmath>
+ #include "Localtime.hh"
+
+ #ifdef LOG4CPP_HAVE_INT64_T
diff --git a/dev-libs/log4cpp/log4cpp-1.1.ebuild b/dev-libs/log4cpp/log4cpp-1.1.ebuild
new file mode 100644
index 000000000000..b1f4dd383a9d
--- /dev/null
+++ b/dev-libs/log4cpp/log4cpp-1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4cpp/log4cpp-1.1.ebuild,v 1.1 2015/01/14 06:48:11 pinkbyte Exp $
+
+EAPI=5
+
+AT_M4DIR="m4"
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="Library of C++ classes for flexible logging to files, syslog and other destinations"
+HOMEPAGE="http://log4cpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~ppc ~s390 ~x86"
+IUSE="doc static-libs test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}/1.0-doc_install_path.patch"
+ "${FILESDIR}/1.0-gcc43.patch"
+ "${FILESDIR}/1.0-asneeded.patch"
+ "${FILESDIR}/${P}-cmath-fix.patch"
+ "${FILESDIR}/${P}-automake-1.13.patch"
+)
+
+S="${WORKDIR}/${PN}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/log4cpp-config
+)
+
+src_prepare() {
+ mv configure.{in,ac} || die
+
+ # Build tests conditionally
+ if ! use test; then
+ sed -i -e '/^SUBDIRS/s/ tests//' Makefile.am || die
+ fi
+
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --without-idsa
+ $(use_enable doc doxygen)
+ )
+ autotools-utils_src_configure
+}