summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-15 17:47:58 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-15 17:47:58 +0000
commit456c61802c1ccc1ec23a49c2b3d5f49e5da415a0 (patch)
tree2b0bde2258be48163ebbbb3d7c1735ec15c4a26c /dev-libs/log4c
parentVersion bump. (diff)
downloadgentoo-2-456c61802c1ccc1ec23a49c2b3d5f49e5da415a0.tar.gz
gentoo-2-456c61802c1ccc1ec23a49c2b3d5f49e5da415a0.tar.bz2
gentoo-2-456c61802c1ccc1ec23a49c2b3d5f49e5da415a0.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-libs/log4c')
-rw-r--r--dev-libs/log4c/ChangeLog8
-rw-r--r--dev-libs/log4c/files/log4c-1.2.4-docdir.patch16
-rw-r--r--dev-libs/log4c/log4c-1.2.4.ebuild43
3 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/log4c/ChangeLog b/dev-libs/log4c/ChangeLog
index 29ece75ba247..f0b16bc84a0f 100644
--- a/dev-libs/log4c/ChangeLog
+++ b/dev-libs/log4c/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/log4c
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.34 2014/02/16 10:35:29 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/ChangeLog,v 1.35 2014/10/15 17:47:58 kensington Exp $
+
+*log4c-1.2.4 (15 Oct 2014)
+
+ 15 Oct 2014; Michael Palimaka <kensington@gentoo.org>
+ +files/log4c-1.2.4-docdir.patch, +log4c-1.2.4.ebuild:
+ Version bump.
16 Feb 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #200380
diff --git a/dev-libs/log4c/files/log4c-1.2.4-docdir.patch b/dev-libs/log4c/files/log4c-1.2.4-docdir.patch
new file mode 100644
index 000000000000..9bbb532da33b
--- /dev/null
+++ b/dev-libs/log4c/files/log4c-1.2.4-docdir.patch
@@ -0,0 +1,16 @@
+Respect the autotools docdir switch. Avoid installing a copy of the license.
+
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -1,10 +1,9 @@
+ man3dir = $(mandir)/man3
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
++docdir = @docdir@
+ docfiles = \
+ $(top_srcdir)/README \
+ $(top_srcdir)/AUTHORS \
+ $(top_srcdir)/NEWS \
+- $(top_srcdir)/COPYING \
+ $(top_srcdir)/ChangeLog
+
+ targets = doxygen.stamp
diff --git a/dev-libs/log4c/log4c-1.2.4.ebuild b/dev-libs/log4c/log4c-1.2.4.ebuild
new file mode 100644
index 000000000000..27bf4ec39ba3
--- /dev/null
+++ b/dev-libs/log4c/log4c-1.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.2.4.ebuild,v 1.1 2014/10/15 17:47:58 kensington Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Log4c is a library of C for flexible logging to files, syslog and other destinations"
+HOMEPAGE="http://log4c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/log4c/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples +expat static-libs"
+
+RDEPEND="expat? ( dev-libs/expat )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}/${P}-docdir.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-expattest
+ $(use_enable debug)
+ $(use_enable doc)
+ )
+
+ use expat || myeconfargs+=( --without-expat )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}