summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-07 07:23:45 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-07 07:23:45 +0000
commit62758c9ed48ad4692eb559e73e15d15bc0023bbf (patch)
tree0925fa2b3cd219301721a51ac6a1c6dfaba964de /dev-libs/libyaml
parentInitial import. (diff)
downloadgentoo-2-62758c9ed48ad4692eb559e73e15d15bc0023bbf.tar.gz
gentoo-2-62758c9ed48ad4692eb559e73e15d15bc0023bbf.tar.bz2
gentoo-2-62758c9ed48ad4692eb559e73e15d15bc0023bbf.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/libyaml')
-rw-r--r--dev-libs/libyaml/ChangeLog9
-rw-r--r--dev-libs/libyaml/libyaml-0.1.5.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-libs/libyaml/ChangeLog b/dev-libs/libyaml/ChangeLog
index 09c8e0e92d5b..51c0af7a2dea 100644
--- a/dev-libs/libyaml/ChangeLog
+++ b/dev-libs/libyaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libyaml
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/ChangeLog,v 1.35 2013/08/08 22:53:43 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/ChangeLog,v 1.36 2014/02/07 07:23:45 radhermit Exp $
+
+*libyaml-0.1.5 (07 Feb 2014)
+
+ 07 Feb 2014; Tim Harder <radhermit@gentoo.org> +libyaml-0.1.5.ebuild:
+ Version bump.
08 Aug 2013; Tim Harder <radhermit@gentoo.org> metadata.xml:
Add myself as maintainer.
diff --git a/dev-libs/libyaml/libyaml-0.1.5.ebuild b/dev-libs/libyaml/libyaml-0.1.5.ebuild
new file mode 100644
index 000000000000..9c1551aa6998
--- /dev/null
+++ b/dev-libs/libyaml/libyaml-0.1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/libyaml-0.1.5.ebuild,v 1.1 2014/02/07 07:23:45 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils eutils libtool
+
+MY_P="${P/lib}"
+
+DESCRIPTION="YAML 1.1 parser and emitter written in C"
+HOMEPAGE="http://pyyaml.org/wiki/LibYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README"
+
+src_prepare() {
+ # conditionally remove tests
+ if ! use test; then
+ sed -i -e 's: tests::g' Makefile* || die
+ fi
+ elibtoolize # for FreeMiNT
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r doc/html/.
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/example-*.c
+ fi
+}