summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-03 23:53:09 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-03 23:53:09 +0000
commitca45374c8a304bdfb144ab129cd2a2ef10365a9e (patch)
tree958bed6388d7592d6e2a183c09637d9cfc9d041d /dev-libs/libxml
parentBump to 0.12.3. Closes #257226 (diff)
downloadgentoo-2-ca45374c8a304bdfb144ab129cd2a2ef10365a9e.tar.gz
gentoo-2-ca45374c8a304bdfb144ab129cd2a2ef10365a9e.tar.bz2
gentoo-2-ca45374c8a304bdfb144ab129cd2a2ef10365a9e.zip
gcc 4.3.3 fix, thanks to Romain Perier. Closes #257309
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libxml')
-rw-r--r--dev-libs/libxml/ChangeLog10
-rw-r--r--dev-libs/libxml/files/open_call_fix.patch11
-rw-r--r--dev-libs/libxml/libxml-1.8.17-r3.ebuild51
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-libs/libxml/ChangeLog b/dev-libs/libxml/ChangeLog
index 5119d9602953..d1a6276e430a 100644
--- a/dev-libs/libxml/ChangeLog
+++ b/dev-libs/libxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libxml
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/ChangeLog,v 1.22 2008/10/14 09:24:33 robbat2 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/ChangeLog,v 1.23 2009/02/03 23:53:09 patrick Exp $
+
+*libxml-1.8.17-r3 (03 Feb 2009)
+
+ 03 Feb 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/open_call_fix.patch, +libxml-1.8.17-r3.ebuild:
+ gcc 4.3.3 fix, thanks to Romain Perier. Closes #257309
14 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
libxml-1.8.17-r2.ebuild:
diff --git a/dev-libs/libxml/files/open_call_fix.patch b/dev-libs/libxml/files/open_call_fix.patch
new file mode 100644
index 000000000000..bcc7c3b71443
--- /dev/null
+++ b/dev-libs/libxml/files/open_call_fix.patch
@@ -0,0 +1,11 @@
+--- old/nanohttp.c 2000-06-28 20:33:46.000000000 +0200
++++ new/nanohttp.c 2009-02-02 13:45:31.199209868 +0100
+@@ -1182,7 +1182,7 @@
+ if (!strcmp(filename, "-"))
+ fd = 0;
+ else {
+- fd = open(filename, O_CREAT | O_WRONLY);
++ fd = open(filename, O_CREAT | O_WRONLY, 0644);
+ if (fd < 0) {
+ xmlNanoHTTPClose(ctxt);
+ return(-1);
diff --git a/dev-libs/libxml/libxml-1.8.17-r3.ebuild b/dev-libs/libxml/libxml-1.8.17-r3.ebuild
new file mode 100644
index 000000000000..320acde372fc
--- /dev/null
+++ b/dev-libs/libxml/libxml-1.8.17-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.17-r3.ebuild,v 1.1 2009/02/03 23:53:09 patrick Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Version 1 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/old/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ >=sys-libs/readline-4.1
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/configure-LANG.patch
+ epatch "${FILESDIR}"/open_call_fix.patch
+}
+
+src_compile() {
+ LIBS="-lncurses" econf || die
+ emake -j1 || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make DESTDIR="${D}" \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ # This link must be fixed
+ rm "${D}"/usr/include/gnome-xml/libxml
+ dosym /usr/include/gnome-xml /usr/include/gnome-xml/libxml
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/usr/include/gnome-xml/libxml ]] ; then
+ rm -f "${ROOT}"/usr/include/gnome-xml/libxml
+ fi
+}