summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-05 03:16:30 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-05 03:16:30 +0000
commitf7ea7d150d445a6dc2ac8daff73facd9cb8508fa (patch)
tree8914790183f79c93a8b97c99b5f88f048f3dc6bd /dev-libs/libxml2
parentQA cleanup: quoted variables, switched to autotools.eclass usage, and changed... (diff)
downloadgentoo-2-f7ea7d150d445a6dc2ac8daff73facd9cb8508fa.tar.gz
gentoo-2-f7ea7d150d445a6dc2ac8daff73facd9cb8508fa.tar.bz2
gentoo-2-f7ea7d150d445a6dc2ac8daff73facd9cb8508fa.zip
Added some code to skip the catalog generation on stage1/stage2, since we won't necessarily have xmlcatalog in the seed stage and libxml2 wouldn't get rebuilt until stage3, ending up with an empty catalog. This fixes bug #208887.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog9
-rw-r--r--dev-libs/libxml2/libxml2-2.6.30-r1.ebuild32
2 files changed, 28 insertions, 13 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 99d3adba5246..7f31617966ac 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.202 2008/01/11 18:13:13 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.203 2008/02/05 03:16:30 wolf31o2 Exp $
+
+ 05 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org>
+ libxml2-2.6.30-r1.ebuild:
+ Added some code to skip the catalog generation on stage1/stage2, since we
+ won't necessarily have xmlcatalog in the seed stage and libxml2 wouldn't get
+ rebuilt until stage3, ending up with an empty catalog. This fixes bug
+ #208887.
11 Jan 2008; Saleem Abdulrasool <compnerd@gentoo.org>
libxml2-2.6.28.ebuild, libxml2-2.6.29.ebuild:
diff --git a/dev-libs/libxml2/libxml2-2.6.30-r1.ebuild b/dev-libs/libxml2/libxml2-2.6.30-r1.ebuild
index 9b17b3f28598..af4ea26b0380 100644
--- a/dev-libs/libxml2/libxml2-2.6.30-r1.ebuild
+++ b/dev-libs/libxml2/libxml2-2.6.30-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.30-r1.ebuild,v 1.1 2008/01/11 17:09:57 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.30-r1.ebuild,v 1.2 2008/02/05 03:16:30 wolf31o2 Exp $
inherit libtool flag-o-matic eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.xmlsoft.org/"
LICENSE="MIT"
SLOT="2"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug doc ipv6 python readline test"
+IUSE="bootstrap build debug doc ipv6 python readline test"
XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
XSTS_NAME_1="xmlschema2002-01-16"
@@ -97,15 +97,23 @@ src_install() {
}
pkg_postinst() {
- # need an XML catalog, so no-one writes to a non-existent one
- CATALOG="${ROOT}etc/xml/catalog"
-
- # we dont want to clobber an existing catalog though,
- # only ensure that one is there
- # <obz@gentoo.org>
- if [ ! -e ${CATALOG} ]; then
- [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
- /usr/bin/xmlcatalog --create > ${CATALOG}
- einfo "Created XML catalog in ${CATALOG}"
+ # We don't want to do the xmlcatalog during stage1/stage2, as xmlcatalog
+ # will not be in / and stage1 builds to ROOT=/tmp/stage1root while stage2
+ # doesn't pull in this package. This fixes bug #208887.
+ if use build || use bootstrap
+ then
+ elog "Skipping XML catalog creation for stage building (bug #208887)."
+ else
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
fi
}