summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-04-01 16:31:19 +0000
committerMarinus Schraal <foser@gentoo.org>2003-04-01 16:31:19 +0000
commit7a2f16c36c861858fed83d4c1db6982c4d0a31ab (patch)
tree5d00048b093c625a5611f1d4bea6f28553c94ea8 /dev-libs/libxml2
parentInitial import. Author of this ebuild is Emmanuel Roger <flynux@prout.be>. (diff)
downloadgentoo-2-7a2f16c36c861858fed83d4c1db6982c4d0a31ab.tar.gz
gentoo-2-7a2f16c36c861858fed83d4c1db6982c4d0a31ab.tar.bz2
gentoo-2-7a2f16c36c861858fed83d4c1db6982c4d0a31ab.zip
new version
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.5.61
-rw-r--r--dev-libs/libxml2/libxml2-2.5.6.ebuild52
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index a436d1e5a817..54f2d68c6f06 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.35 2003/03/27 18:45:49 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.36 2003/04/01 16:27:52 foser Exp $
+
+*libxml2-2.5.6 (01 Apr 2003)
+
+ 01 Apr 2003; foser <foser@gentoo.org> libxml2-2.5.6.ebuild :
+ New version
*libxml2-2.5.5 (27 Mar 2003)
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.5.6 b/dev-libs/libxml2/files/digest-libxml2-2.5.6
new file mode 100644
index 000000000000..d1b964a4e59e
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.5.6
@@ -0,0 +1 @@
+MD5 5e8f3b788040fbdfb7e427cfec443bb2 libxml2-2.5.6.tar.bz2 2360070
diff --git a/dev-libs/libxml2/libxml2-2.5.6.ebuild b/dev-libs/libxml2/libxml2-2.5.6.ebuild
new file mode 100644
index 000000000000..49569a0cdf6a
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.5.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.5.6.ebuild,v 1.1 2003/04/01 16:27:52 foser Exp $
+
+inherit eutils libtool gnome.org
+
+IUSE="python readline"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+SLOT="2"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf=""
+
+ # This breaks gnome2 (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+ #use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf --with-zlib ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}