summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-11-08 17:56:38 +0000
committerMarinus Schraal <foser@gentoo.org>2002-11-08 17:56:38 +0000
commit776769721f13e4aadaab8b61110cec7107f4b76c (patch)
tree695ecc0cc4c31b7599195ff86e8094f0ec820b86 /dev-libs/libxml2
parentNew ebuild added (4792) thanks to Pierre-Henri Jondot (diff)
downloadgentoo-2-776769721f13e4aadaab8b61110cec7107f4b76c.tar.gz
gentoo-2-776769721f13e4aadaab8b61110cec7107f4b76c.tar.bz2
gentoo-2-776769721f13e4aadaab8b61110cec7107f4b76c.zip
Few fixes and masking for move to stable
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog6
-rw-r--r--dev-libs/libxml2/libxml2-2.4.26.ebuild28
2 files changed, 22 insertions, 12 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index b5c6f9bf9bec..9989660ffc6c 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.16 2002/10/27 14:06:53 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.17 2002/11/08 17:56:38 foser Exp $
*libxml2-2.4.27 (27 Oct 2002)
- 27 Oct 2002; foser <foser@gentoo.org> libxml2-2.4.26.ebuild :
+ 07 Nov 2002; foser <foser@gentoo.org> libxml2-2.4.26.ebuild :
+ Fixed the ebuild a bit. Now USE flags for deps.
+ 27 Oct 2002; foser <foser@gentoo.org> libxml2-2.4.26.ebuild :
Gnome 2.1 commit
*libxml2-2.4.24 (06 Sep 2002)
diff --git a/dev-libs/libxml2/libxml2-2.4.26.ebuild b/dev-libs/libxml2/libxml2-2.4.26.ebuild
index 58dd65d6a7df..753bde7fedac 100644
--- a/dev-libs/libxml2/libxml2-2.4.26.ebuild
+++ b/dev-libs/libxml2/libxml2-2.4.26.ebuild
@@ -1,28 +1,36 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.26.ebuild,v 1.1 2002/10/27 14:06:53 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.26.ebuild,v 1.2 2002/11/08 17:56:38 foser Exp $
-inherit libtool gnome2 debug
+inherit libtool gnome2
+IUSE="zlib python readline"
S=${WORKDIR}/${P}
DESCRIPTION="Version 2 of the library to manipulate XML files"
HOMEPAGE="http://www.gnome.org/"
-DEPEND=">=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.1
- >=sys-libs/zlib-1.1.4"
-
+DEPEND="zlib? ( sys-libs/zlib )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
SLOT="2"
LICENSE="MIT"
-KEYWORDS="x86 sparc sparc64 ppc alpha"
+KEYWORDS="~x86 ~sparc ~sparc64 ~ppc ~alpha"
src_compile() {
# Fix .la files of python site packages
elibtoolize
- econf --with-zlib || die
-# patch -p0 < ${FILESDIR}/Makefile-py.patch || die "no, patch failed"
- make || die
+ local myconf
+
+ use zlib && myconf="--with-zlib" || myconf="--without-zlib"
+ use python && myconf="${myconf} --with-python" \
+ || myconf="${myconf} --without-python"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ econf ${myconf} || die
+ emake || die
}
src_install() {