summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-15 09:57:11 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-15 09:57:11 +0000
commit5533a3bf1f63f85b0849bcf50a89d09de121b5b4 (patch)
treedd053dc5a36080175ff49aaf540f3ba632e5549e /dev-libs/libxml2
parentversion bump, bug 531448, 549104, thanks Karl-Johan Karlsson and Ondrej Sury (diff)
downloadgentoo-2-5533a3bf1f63f85b0849bcf50a89d09de121b5b4.tar.gz
gentoo-2-5533a3bf1f63f85b0849bcf50a89d09de121b5b4.tar.bz2
gentoo-2-5533a3bf1f63f85b0849bcf50a89d09de121b5b4.zip
Fix from Chromium OS for cross-compiling.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog6
-rw-r--r--dev-libs/libxml2/files/libxml2-2.9.2-cross-compile.patch17
-rw-r--r--dev-libs/libxml2/libxml2-2.9.2-r1.ebuild4
3 files changed, 25 insertions, 2 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 3b6725fc63e8..47480429911b 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libxml2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.452 2015/04/28 07:28:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.453 2015/05/15 09:57:11 vapier Exp $
+
+ 15 May 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/libxml2-2.9.2-cross-compile.patch, libxml2-2.9.2-r1.ebuild:
+ Fix from Chromium OS for cross-compiling.
28 Apr 2015; Agostino Sarubbo <ago@gentoo.org> libxml2-2.9.2-r1.ebuild:
Stable for alpha, wrt bug #546720
diff --git a/dev-libs/libxml2/files/libxml2-2.9.2-cross-compile.patch b/dev-libs/libxml2/files/libxml2-2.9.2-cross-compile.patch
new file mode 100644
index 000000000000..447222eeefb7
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.9.2-cross-compile.patch
@@ -0,0 +1,17 @@
+https://bugzilla.gnome.org/show_bug.cgi?id=749416
+
+do not use -L$Z_DIR/lib when Z_DIR isn't actually set
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -392,7 +392,9 @@ if test "$with_zlib" = "no"; then
+ else
+ AC_CHECK_HEADERS(zlib.h,
+ [SAVE_LDFLAGS="${LDFLAGS}"
+- LDFLAGS="-L${Z_DIR}/lib"
++ if test "x${Z_DIR}" != "x"; then
++ LDFLAGS="${LDFLAGS} -L${Z_DIR}/lib"
++ fi
+ AC_CHECK_LIB(z, gzread,[
+ AC_DEFINE([HAVE_LIBZ], [1], [Have compression library])
+ WITH_ZLIB=1
diff --git a/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild b/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild
index b487757d5119..c5a2b41ef20a 100644
--- a/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild
+++ b/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild,v 1.9 2015/04/28 07:28:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.9.2-r1.ebuild,v 1.10 2015/05/15 09:57:11 vapier Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -78,6 +78,8 @@ src_prepare() {
# epunt_cxx # if we don't eautoreconf
+ epatch "${FILESDIR}"/${PN}-2.9.2-cross-compile.patch
+
# Important patches from master
epatch \
"${FILESDIR}/${PN}-2.9.2-revert-missing-initialization.patch" \