summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-09-06 19:59:55 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-09-06 19:59:55 +0000
commit0066b576c0426e55af3fa09c069246cd443b6a00 (patch)
tree3341c681a46436739a904dd411d53aca7c2c170a /dev-libs/libxml2
parentRemove old revision. (diff)
downloadgentoo-2-0066b576c0426e55af3fa09c069246cd443b6a00.tar.gz
gentoo-2-0066b576c0426e55af3fa09c069246cd443b6a00.tar.bz2
gentoo-2-0066b576c0426e55af3fa09c069246cd443b6a00.zip
New release: 2.6.21
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog9
-rw-r--r--dev-libs/libxml2/Manifest6
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.6.211
-rw-r--r--dev-libs/libxml2/libxml2-2.6.21.ebuild88
4 files changed, 101 insertions, 3 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 5b1466526658..b93e595fb113 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.132 2005/09/06 15:12:22 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.133 2005/09/06 19:59:54 leonardop Exp $
+
+*libxml2-2.6.21 (06 Sep 2005)
+
+ 06 Sep 2005; Leonardo Boshell <leonardop@gentoo.org>
+ +libxml2-2.6.21.ebuild:
+ New version. Re-added 'debug' USE flag for other switches. Apply the
+ 'readline' flag to --with-history switch.
06 Sep 2005; Markus Rothe <corsair@gentoo.org> libxml2-2.6.20-r2.ebuild:
Stable on ppc64
diff --git a/dev-libs/libxml2/Manifest b/dev-libs/libxml2/Manifest
index e7f83bff023a..3e2bb0c8ed76 100644
--- a/dev-libs/libxml2/Manifest
+++ b/dev-libs/libxml2/Manifest
@@ -1,6 +1,8 @@
MD5 2aecebf4d7917c66dc60235c56c7ec99 ChangeLog 15708
-MD5 261427afd62b7a24ac717eb4483cd668 libxml2-2.6.19.ebuild 2039
-MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 219fd0a819408b19b0c6829acd43b8e9 libxml2-2.6.20-r2.ebuild 2367
+MD5 7f56277fff9d752ee057ff8e46d87d89 libxml2-2.6.21.ebuild 2386
+MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 261427afd62b7a24ac717eb4483cd668 libxml2-2.6.19.ebuild 2039
+MD5 c402e1e3e6b8059d00e664a3b13b2954 files/digest-libxml2-2.6.21 68
MD5 4afb7240de6f033dc7cd147c38d2b06f files/digest-libxml2-2.6.20-r2 68
MD5 761d617849c91c951713a1411f3c1cff files/digest-libxml2-2.6.19 68
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.6.21 b/dev-libs/libxml2/files/digest-libxml2-2.6.21
new file mode 100644
index 000000000000..f788bb038c10
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.6.21
@@ -0,0 +1 @@
+MD5 2fb1739c55461618925a0524b67c9f91 libxml2-2.6.21.tar.bz2 3216209
diff --git a/dev-libs/libxml2/libxml2-2.6.21.ebuild b/dev-libs/libxml2/libxml2-2.6.21.ebuild
new file mode 100644
index 000000000000..98c111c783ba
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.6.21.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.21.ebuild,v 1.1 2005/09/06 19:59:54 leonardop Exp $
+
+inherit libtool gnome.org flag-o-matic eutils
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug doc ipv6 python readline static"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+ unpack "${A}"
+
+ epunt_cxx
+}
+
+src_compile() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ local myconf="--with-zlib \
+ $(use_with debug mem-debug) \
+ $(use_with debug run-debug) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with readline history) \
+ $(use_enable static) \
+ $(use_enable ipv6)"
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ econf $myconf || die "Configuration failed"
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86766, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find ${S} -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+
+ emake || die "Copilation failed"
+
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO*
+
+ use doc || rm -rf ${D}/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}/etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}/etc/xml" ] || mkdir -p "${ROOT}/etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+}