summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-23 06:45:43 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-23 06:45:43 +0000
commit78448b00337cc2aeab309951fa6cc7b42d92c15b (patch)
tree30dd9cff6d42d6ccc748ec5dd17c78b2170e43b4 /dev-libs/libuv
parentVersion bump. (diff)
downloadgentoo-2-78448b00337cc2aeab309951fa6cc7b42d92c15b.tar.gz
gentoo-2-78448b00337cc2aeab309951fa6cc7b42d92c15b.tar.bz2
gentoo-2-78448b00337cc2aeab309951fa6cc7b42d92c15b.zip
version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-libs/libuv')
-rw-r--r--dev-libs/libuv/ChangeLog8
-rw-r--r--dev-libs/libuv/files/libuv-0.11.8-Werror.patch61
-rw-r--r--dev-libs/libuv/libuv-0.11.8.ebuild36
3 files changed, 104 insertions, 1 deletions
diff --git a/dev-libs/libuv/ChangeLog b/dev-libs/libuv/ChangeLog
index 9affe838c264..876cb0c7f4c9 100644
--- a/dev-libs/libuv/ChangeLog
+++ b/dev-libs/libuv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libuv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.1 2013/08/01 16:06:11 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.2 2013/08/23 06:45:43 hasufell Exp $
+
+*libuv-0.11.8 (23 Aug 2013)
+
+ 23 Aug 2013; Julian Ospald <hasufell@gentoo.org> +libuv-0.11.8.ebuild,
+ +files/libuv-0.11.8-Werror.patch:
+ version bump
*libuv-0.11.6 (01 Aug 2013)
diff --git a/dev-libs/libuv/files/libuv-0.11.8-Werror.patch b/dev-libs/libuv/files/libuv-0.11.8-Werror.patch
new file mode 100644
index 000000000000..ec0ce783a508
--- /dev/null
+++ b/dev-libs/libuv/files/libuv-0.11.8-Werror.patch
@@ -0,0 +1,61 @@
+From bf325c01d737fd7ef9d32e75531dd0649809af0c Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@posteo.de>
+Date: Fri, 23 Aug 2013 08:32:59 +0200
+Subject: [PATCH] build: add --enable-Werror switch
+
+There are too many cases where general -Werror causes compile
+failures without good reason including:
+* new warnings on version bumps of GCC/GLIBC the developer was
+ not aware of at the point of coding
+* some autoconf checks will fail badly
+* libraries adding deprecated API warnings although that API
+ is still working/supported
+* on less known architectures we may get different/more
+ warnings than on common ones
+* random breakage depending on what distro/architecture/library
+ version/kernel/userland the developer was testing "-Werror" on
+
+So we add a switch and have it default to off, since it
+is only interesting for development.
+
+Specific flags such as -Werror=implicit-function-declaration
+might be ok to force unconditionally for everyone depending
+on what we expect from the code.
+---
+ configure.ac | 13 ++++++++++++-
+ 1 file changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index d9760a3..bcd9303 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,7 +16,7 @@ AC_PREREQ(2.57)
+ AC_INIT([libuv], [0.11.5], [https://github.com/joyent/libuv/issues])
+ AC_CONFIG_MACRO_DIR([m4])
+ m4_include([m4/libuv-extra-automake-flags.m4])
+-AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects] UV_EXTRA_AUTOMAKE_FLAGS)
++AM_INIT_AUTOMAKE([-Wall foreign subdir-objects] UV_EXTRA_AUTOMAKE_FLAGS)
+ AC_CANONICAL_HOST
+ AC_ENABLE_SHARED
+ AC_ENABLE_STATIC
+@@ -37,6 +37,17 @@ AC_CHECK_LIB([rt], [clock_gettime])
+ AC_CHECK_LIB([sendfile], [sendfile])
+ AC_CHECK_LIB([socket], [socket])
+ AC_SYS_LARGEFILE
++
++# only use this for development
++AC_ARG_ENABLE([Werror],
++ [AS_HELP_STRING([--enable-Werror],
++ [turn all warnings into errors [default=no]])],
++ [enable_werror=$enableval],
++ [enable_werror="no"])
++
++AS_IF([test "x$enable_werror" != "xno"],
++ [CFLAGS="$CFLAGS -Werror"])
++
+ AM_CONDITIONAL([AIX], [AS_CASE([$host_os], [aix*], [true], [false])])
+ AM_CONDITIONAL([DARWIN], [AS_CASE([$host_os], [darwin*], [true], [false])])
+ AM_CONDITIONAL([FREEBSD], [AS_CASE([$host_os], [freebsd*], [true], [false])])
+--
+1.8.1.6
+
diff --git a/dev-libs/libuv/libuv-0.11.8.ebuild b/dev-libs/libuv/libuv-0.11.8.ebuild
new file mode 100644
index 000000000000..322e1dece801
--- /dev/null
+++ b/dev-libs/libuv/libuv-0.11.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-0.11.8.ebuild,v 1.1 2013/08/23 06:45:43 hasufell Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="A new platform layer for Node"
+HOMEPAGE="https://github.com/joyent/libuv"
+SRC_URI="https://github.com/joyent/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Werror.patch
+
+ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+ > m4/libuv-extra-automake-flags.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-Werror
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}