summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-06-10 02:36:05 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-06-10 02:36:05 +0000
commit819f0403601d16c4430512467bfc8fd1ba0a798f (patch)
tree9ba6a5557740738af69bc6d2f7b7aea020a7f887 /dev-libs/libtommath
parentHost tarball on Gentoo's mirrors (diff)
downloadgentoo-2-819f0403601d16c4430512467bfc8fd1ba0a798f.tar.gz
gentoo-2-819f0403601d16c4430512467bfc8fd1ba0a798f.tar.bz2
gentoo-2-819f0403601d16c4430512467bfc8fd1ba0a798f.zip
Version bump. bug #162161. Thanks to hawking & Rafa# Mu#y#o for the contributions
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/ChangeLog9
-rw-r--r--dev-libs/libtommath/files/libtommath-0.41-LDFLAGS.patch28
-rw-r--r--dev-libs/libtommath/libtommath-0.41.ebuild33
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/libtommath/ChangeLog b/dev-libs/libtommath/ChangeLog
index 4f23bd71bd0e..ace4f75af5e8 100644
--- a/dev-libs/libtommath/ChangeLog
+++ b/dev-libs/libtommath/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libtommath
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.21 2008/02/22 14:02:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.22 2008/06/10 02:36:04 darkside Exp $
+
+*libtommath-0.41 (10 Jun 2008)
+
+ 10 Jun 2008; Jeremy Olexa <darkside@gentoo.org>
+ +files/libtommath-0.41-LDFLAGS.patch, +libtommath-0.41.ebuild:
+ Version bump. bug #162161. Thanks to hawking & Rafa# Mu#y#o for the
+ contributions
22 Feb 2008; Diego Pettenò <flameeyes@gentoo.org>
libtommath-0.36-r1.ebuild:
diff --git a/dev-libs/libtommath/files/libtommath-0.41-LDFLAGS.patch b/dev-libs/libtommath/files/libtommath-0.41-LDFLAGS.patch
new file mode 100644
index 000000000000..1997f61a2fa2
--- /dev/null
+++ b/dev-libs/libtommath/files/libtommath-0.41-LDFLAGS.patch
@@ -0,0 +1,28 @@
+--- makefile.shared.old 2007-03-11 00:45:11.000000000 +0100
++++ makefile.shared 2007-11-06 17:21:45.000000000 +0100
+@@ -83,20 +83,20 @@
+ objs: $(OBJECTS)
+
+ $(LIBNAME): $(OBJECTS)
+- libtool --mode=link gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
++ libtool --mode=link --tag=CC gcc $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+
+ install: $(LIBNAME)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
+ libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
+ install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+- install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
++ install -m 644 -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
+
+ test: $(LIBNAME) demo/demo.o
+ gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- libtool --mode=link gcc -o test demo/demo.o $(LIBNAME_S)
++ libtool --mode=link gcc $(LDFLAGS) -o test demo/demo.o $(LIBNAME_S)
+
+ mtest: test
+- cd mtest ; gcc $(CFLAGS) mtest.c -o mtest
++ cd mtest ; gcc $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
+
+ timing: $(LIBNAME)
+- gcc $(CFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
++ libtool --mode=link gcc $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
diff --git a/dev-libs/libtommath/libtommath-0.41.ebuild b/dev-libs/libtommath/libtommath-0.41.ebuild
new file mode 100644
index 000000000000..0829d27db0d6
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-0.41.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.41.ebuild,v 1.1 2008/06/10 02:36:04 darkside Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
+HOMEPAGE="http://www.libtom.org/"
+SRC_URI="http://www.libtom.org/files/ltm-${PV}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+}
+
+src_compile() {
+ emake -f makefile.shared IGNORE_SPEED=1 || die "emake failed"
+}
+
+src_install() {
+ make -f makefile.shared install DESTDIR="${D}" LIBPATH="/usr/$(get_libdir)" || die
+ dodoc changes.txt *.pdf
+ docinto demo ; dodoc demo/*.c
+}