summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2011-04-12 18:19:40 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2011-04-12 18:19:40 +0000
commitc6400b2eab3b96c78009b3e2f050b9a402e18a4a (patch)
tree5d15e6af4777a46c94d9f1a7870b0378d1bb79fc /dev-libs/libsigsegv/libsigsegv-2.10.ebuild
parentx86 stable per bug 358715 (diff)
downloadgentoo-2-c6400b2eab3b96c78009b3e2f050b9a402e18a4a.tar.gz
gentoo-2-c6400b2eab3b96c78009b3e2f050b9a402e18a4a.tar.bz2
gentoo-2-c6400b2eab3b96c78009b3e2f050b9a402e18a4a.zip
Version bump
(Portage version: 2.1.9.45/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libsigsegv/libsigsegv-2.10.ebuild')
-rw-r--r--dev-libs/libsigsegv/libsigsegv-2.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libsigsegv/libsigsegv-2.10.ebuild b/dev-libs/libsigsegv/libsigsegv-2.10.ebuild
new file mode 100644
index 000000000000..8560207b6eaf
--- /dev/null
+++ b/dev-libs/libsigsegv/libsigsegv-2.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigsegv/libsigsegv-2.10.ebuild,v 1.1 2011/04/12 18:19:40 pchrist Exp $
+
+DESCRIPTION="library for handling page faults in user mode"
+HOMEPAGE="http://libsigsegv.sourceforge.net/"
+SRC_URI="mirror://gnu/libsigsegv/${P}.tar.gz"
+
+EAPI="2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_configure () {
+ econf --enable-shared || die "Configure phase failed"
+}
+
+src_test () {
+ if [[ ${FEATURES} = *sandbox* ]]
+ then
+ ewarn "It is known that the stackoverflow"
+ ewarn "tests will fail with sandbox enabled."
+ fi
+ emake check || die "Tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog* NEWS PORTING README
+}