summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-15 08:39:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-15 08:39:17 +0000
commit919a61fc08c0297f89700f4c101fae37d870ace3 (patch)
tree0ae64710aa49b5d1b5f54eb3a92a75c4277eeaa7 /dev-libs/librra
parentold (diff)
downloadgentoo-2-919a61fc08c0297f89700f4c101fae37d870ace3.tar.gz
gentoo-2-919a61fc08c0297f89700f4c101fae37d870ace3.tar.bz2
gentoo-2-919a61fc08c0297f89700f4c101fae37d870ace3.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/librra')
-rw-r--r--dev-libs/librra/ChangeLog7
-rw-r--r--dev-libs/librra/librra-0.16.ebuild52
-rw-r--r--dev-libs/librra/metadata.xml4
3 files changed, 58 insertions, 5 deletions
diff --git a/dev-libs/librra/ChangeLog b/dev-libs/librra/ChangeLog
index 8c7d7470338f..140ccbef6f7d 100644
--- a/dev-libs/librra/ChangeLog
+++ b/dev-libs/librra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/librra
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librra/ChangeLog,v 1.2 2012/05/04 18:35:56 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librra/ChangeLog,v 1.3 2012/06/15 08:39:17 ssuominen Exp $
+
+*librra-0.16 (15 Jun 2012)
+
+ 15 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +librra-0.16.ebuild:
+ Version bump.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> librra-0.14.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-libs/librra/librra-0.16.ebuild b/dev-libs/librra/librra-0.16.ebuild
new file mode 100644
index 000000000000..a7a95e7985c9
--- /dev/null
+++ b/dev-libs/librra/librra-0.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librra/librra-0.16.ebuild,v 1.1 2012/06/15 08:39:17 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.7"
+
+inherit python
+
+DESCRIPTION="Implements the RRA protocol, for syncing pre WM-2005 PIM data, and files for all versions"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python recurrence static-libs"
+
+RDEPEND=">=app-pda/synce-core-0.16[python?]
+ >=dev-libs/libmimedir-0.5.1
+ python? ( >=dev-python/pyrex-0.9.6 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable recurrence) \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README TODO
+ newdoc lib/README README.lib
+ newdoc src/README README.src
+
+ # prune_libtool_files() from eutils.eclass fails wrt #421197
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # Always remove static archive from site-packages
+ use static-libs && find "${ED}" -name pyrra.a -exec rm -f {} +
+}
diff --git a/dev-libs/librra/metadata.xml b/dev-libs/librra/metadata.xml
index 765d088d6659..6db1a7a11f06 100644
--- a/dev-libs/librra/metadata.xml
+++ b/dev-libs/librra/metadata.xml
@@ -2,10 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>pda</herd>
- <maintainer>
- <email>ssuominen@gentoo.org</email>
- <name>Samuli Suominen</name>
- </maintainer>
<use>
<flag name="recurrence">Enable recurrence support (EXPERIMENTAL)</flag>
</use>