summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-06-23 01:17:33 +0000
committerAron Griffis <agriffis@gentoo.org>2005-06-23 01:17:33 +0000
commit6caeefff6339145b237840f148732da017b56880 (patch)
tree3a02aac6b9c614007968cdc7ab9785b24b109f81 /dev-libs/librep
parentRESTRICT=maketest -> RESTRICT=test (diff)
downloadgentoo-2-6caeefff6339145b237840f148732da017b56880.tar.gz
gentoo-2-6caeefff6339145b237840f148732da017b56880.tar.bz2
gentoo-2-6caeefff6339145b237840f148732da017b56880.zip
Use tc-getCC to solve libtool tag problems #70514
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'dev-libs/librep')
-rw-r--r--dev-libs/librep/ChangeLog9
-rw-r--r--dev-libs/librep/Manifest7
-rw-r--r--dev-libs/librep/files/digest-librep-0.17-r11
-rw-r--r--dev-libs/librep/librep-0.17-r1.ebuild59
4 files changed, 71 insertions, 5 deletions
diff --git a/dev-libs/librep/ChangeLog b/dev-libs/librep/ChangeLog
index ac52808cf55e..fd2325b9419b 100644
--- a/dev-libs/librep/ChangeLog
+++ b/dev-libs/librep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/librep
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.24 2004/10/14 03:11:54 lu_zero Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.25 2005/06/23 01:17:33 agriffis Exp $
+
+*librep-0.17-r1 (23 Jun 2005)
+
+ 23 Jun 2005; Aron Griffis <agriffis@gentoo.org> +librep-0.17-r1.ebuild:
+ Use tc-getCC to solve libtool tag problems #70514
14 Oct 2004; Luca Barbato <lu_zero@gentoo.org> librep-0.17.ebuild:
Fixed bug #67428
diff --git a/dev-libs/librep/Manifest b/dev-libs/librep/Manifest
index e1a37b788114..1b1a15adac51 100644
--- a/dev-libs/librep/Manifest
+++ b/dev-libs/librep/Manifest
@@ -1,7 +1,8 @@
-MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
-MD5 480474336414d1a7f92e33f628fb9a8e librep-0.17.ebuild 1281
MD5 cb0797d43ae9e4509e2103ffa7426a7d librep-0.16.2.ebuild 1224
+MD5 aea9884c0e9349c4b3436fe7a9d15553 librep-0.17-r1.ebuild 1318
MD5 2ee6de1fcf9d584fa9ee5cdd1828ddac ChangeLog 3541
+MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
+MD5 07a234e62724c3d45a1b69f1c04cd0a9 files/digest-librep-0.17-r1 64
+MD5 07a234e62724c3d45a1b69f1c04cd0a9 files/digest-librep-0.17 64
MD5 8c655620e7f5d0dc0ee9b8ef6351158d files/librep-0.15.2-exec.patch 425
MD5 f3efabdde310e7d8da74859ea2af221c files/digest-librep-0.16.2 65
-MD5 07a234e62724c3d45a1b69f1c04cd0a9 files/digest-librep-0.17 64
diff --git a/dev-libs/librep/files/digest-librep-0.17-r1 b/dev-libs/librep/files/digest-librep-0.17-r1
new file mode 100644
index 000000000000..491723e8262f
--- /dev/null
+++ b/dev-libs/librep/files/digest-librep-0.17-r1
@@ -0,0 +1 @@
+MD5 ad4ad851ff9f82a5d61024cd96bc2998 librep-0.17.tar.gz 1195890
diff --git a/dev-libs/librep/librep-0.17-r1.ebuild b/dev-libs/librep/librep-0.17-r1.ebuild
new file mode 100644
index 000000000000..19c534c5293b
--- /dev/null
+++ b/dev-libs/librep/librep-0.17-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17-r1.ebuild,v 1.1 2005/06/23 01:17:33 agriffis Exp $
+
+IUSE="readline"
+
+inherit libtool toolchain-funcs
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://librep.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ >=sys-devel/automake-1.6.1-r5"
+
+src_compile() {
+ elibtoolize
+
+ local myconf
+
+ use readline \
+ && myconf='--with-readline' \
+ || myconf='--without-readline'
+ use ppc && myconf="${myconf} --with-stack-direction=1"
+ LC_ALL=""
+ LINGUAS=""
+ LANG=""
+ export LC_ALL LINGUAS LANG
+
+ CC=$(tc-getCC) econf \
+ --libexecdir=/usr/lib \
+ --without-gmp \
+ ${myconf} || die "configure failure"
+
+ make host_type=${CHOST} || die "compile failure"
+}
+
+src_install() {
+ make install \
+ host_type=${CHOST} \
+ DESTDIR=${D} \
+ aclocaldir=/usr/share/aclocal \
+ infodir=/usr/share/info || die
+
+ insinto /usr/include
+ doins src/rep_config.h
+
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO DOC TREE
+ docinto doc
+ dodoc doc/*
+}