summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-10 13:10:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-10 13:10:42 +0000
commitccf255c43e368ce3eac87de1eb726e0237b826cd (patch)
tree70c4958c96edca75442756d1026de0e60494fb10 /dev-libs/libpqxx
parentInstall sounds and pixmaps for pieces under SITEETC. (diff)
downloadgentoo-2-ccf255c43e368ce3eac87de1eb726e0237b826cd.tar.gz
gentoo-2-ccf255c43e368ce3eac87de1eb726e0237b826cd.tar.bz2
gentoo-2-ccf255c43e368ce3eac87de1eb726e0237b826cd.zip
Bump to 3.0.2, fixes #265412.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libpqxx')
-rw-r--r--dev-libs/libpqxx/ChangeLog7
-rw-r--r--dev-libs/libpqxx/libpqxx-3.0.2.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/libpqxx/ChangeLog b/dev-libs/libpqxx/ChangeLog
index 6e019b56ea6b..7cc21c7c6ccb 100644
--- a/dev-libs/libpqxx/ChangeLog
+++ b/dev-libs/libpqxx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libpqxx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.62 2009/07/19 11:55:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.63 2009/09/10 13:10:42 patrick Exp $
+
+*libpqxx-3.0.2 (10 Sep 2009)
+
+ 10 Sep 2009; Patrick Lauer <patrick@gentoo.org> +libpqxx-3.0.2.ebuild:
+ Bump to 3.0.2, fixes #265412.
19 Jul 2009; nixnut <nixnut@gentoo.org> libpqxx-2.6.9.ebuild:
ppc stable #249248
diff --git a/dev-libs/libpqxx/libpqxx-3.0.2.ebuild b/dev-libs/libpqxx/libpqxx-3.0.2.ebuild
new file mode 100644
index 000000000000..281b51b2d1fa
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-3.0.2.ebuild,v 1.1 2009/09/10 13:10:42 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="C++ client API for PostgreSQL. The standard front-end for writing C++ programs that use PostgreSQL. Supersedes older libpq++ interface."
+SRC_URI="http://pqxx.org/download/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/postgresql-base"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # should be safe enough to remove the lines directly from configure,
+ # since it's copied directly from configure.ac
+ sed -i \
+ -e 's/\(gcc_visibility\)=yes/\1=no/g' \
+ -e 's@\(#define PQXX_HAVE_GCC_VISIBILITY 1\)@/* \1 */@g' \
+ -e '/-Werror/d' \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+ dohtml -r doc/html/*
+}
+
+src_test() {
+ ewarn "The tests need a running PostgreSQL server and an existing database!"
+ ewarn "You can set the following environment variables to change the connection parameters:"
+ ewarn "PGDATABASE (default: username, probably root)"
+ ewarn "PGHOST (default: localhost)"
+ ewarn "PGPORT (default: pg's UNIX domain-socket)"
+ ewarn "PGUSER (default: username, probably root)"
+ epause 10
+
+ if [[ -n ${PGDATABASE} ]] ; then
+ cd "${S}/test"
+ # Working around a mysterious bug in gcc-4.1
+ sed -i -e 's/-O2/-O1/' Makefile
+ emake -j1 check || die "emake check failed"
+ else
+ ewarn "Tests skipped since PGDATABASE is not defined or empty"
+ fi
+}