summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-05-09 20:34:02 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-05-09 20:34:02 +0000
commit0f5263dcde5bf6d8240d7a3e5c79cd7e436dcf07 (patch)
treea813229200715dde3f5d45f747761423708944d2 /dev-libs/libpqxx
parentStable on ppc. (diff)
downloadgentoo-2-0f5263dcde5bf6d8240d7a3e5c79cd7e436dcf07.tar.gz
gentoo-2-0f5263dcde5bf6d8240d7a3e5c79cd7e436dcf07.tar.bz2
gentoo-2-0f5263dcde5bf6d8240d7a3e5c79cd7e436dcf07.zip
Fixed include header path.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-libs/libpqxx')
-rw-r--r--dev-libs/libpqxx/ChangeLog6
-rw-r--r--dev-libs/libpqxx/files/libpqxx-2.5.1-gentoo.patch79
-rw-r--r--dev-libs/libpqxx/libpqxx-2.5.1.ebuild4
3 files changed, 87 insertions, 2 deletions
diff --git a/dev-libs/libpqxx/ChangeLog b/dev-libs/libpqxx/ChangeLog
index f5f0dd69fd2d..ef2d79e26961 100644
--- a/dev-libs/libpqxx/ChangeLog
+++ b/dev-libs/libpqxx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libpqxx
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.17 2005/05/09 00:35:13 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.18 2005/05/09 20:34:02 nakano Exp $
+
+ 09 May 2005; Masatomo Nakano <nakano@gentoo.org>
+ +files/libpqxx-2.5.1-gentoo.patch, libpqxx-2.5.1.ebuild:
+ Fixed include header path.
*libpqxx-2.5.1 (09 May 2005)
diff --git a/dev-libs/libpqxx/files/libpqxx-2.5.1-gentoo.patch b/dev-libs/libpqxx/files/libpqxx-2.5.1-gentoo.patch
new file mode 100644
index 000000000000..d7802ba875d3
--- /dev/null
+++ b/dev-libs/libpqxx/files/libpqxx-2.5.1-gentoo.patch
@@ -0,0 +1,79 @@
+diff -Naru libpqxx-2.5.1.org/configure libpqxx-2.5.1/configure
+--- libpqxx-2.5.1.org/configure 2005-05-06 11:09:52.000000000 +0100
++++ libpqxx-2.5.1/configure 2005-05-09 21:25:38.000000000 +0100
+@@ -20183,73 +20183,8 @@
+ echo "$as_me:$LINENO: result: $cpp_pragma_message" >&5
+ echo "${ECHO_T}$cpp_pragma_message" >&6
+
+-# Find PostgreSQL includes and libraries
+-for ac_prog in pg_config
+-do
+- # Extract the first word of "$ac_prog", so it can be a program name with args.
+-set dummy $ac_prog; ac_word=$2
+-echo "$as_me:$LINENO: checking for $ac_word" >&5
+-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+-if test "${ac_cv_path_PG_CONFIG+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- case $PG_CONFIG in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_PG_CONFIG="$PG_CONFIG" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_PG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
+- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+-done
+-
+- ;;
+-esac
+-fi
+-PG_CONFIG=$ac_cv_path_PG_CONFIG
+-
+-if test -n "$PG_CONFIG"; then
+- echo "$as_me:$LINENO: result: $PG_CONFIG" >&5
+-echo "${ECHO_T}$PG_CONFIG" >&6
+-else
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-fi
+-
+- test -n "$PG_CONFIG" && break
+-done
+-
+-if test -z "$PG_CONFIG" || test ! -r "$PG_CONFIG"; then
+- { { echo "$as_me:$LINENO: error:
+-PostgreSQL configuration script pg_config not found. Make sure this is in your
+-command path before configuring. Without it, the configure script has no way to
+-find the right location for the libpq library and its headers.
+-" >&5
+-echo "$as_me: error:
+-PostgreSQL configuration script pg_config not found. Make sure this is in your
+-command path before configuring. Without it, the configure script has no way to
+-find the right location for the libpq library and its headers.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-with_postgres_include=`$PG_CONFIG --includedir`
+-{ echo "$as_me:$LINENO: using PostgreSQL headers at $with_postgres_include" >&5
+-echo "$as_me: using PostgreSQL headers at $with_postgres_include" >&6;}
+-with_postgres_lib=`$PG_CONFIG --libdir`
+-{ echo "$as_me:$LINENO: using PostgreSQL libraries at $with_postgres_lib" >&5
+-echo "$as_me: using PostgreSQL libraries at $with_postgres_lib" >&6;}
+-
+-
+-
++with_postgres_include=/usr/include/postgresql
++with_postgres_lib=/usr/lib
+ POSTGRES_LIB="-L${with_postgres_lib} -R${with_postgres_lib} -lpq"
+
+ POSTGRES_INCLUDE="-I${with_postgres_include}"
diff --git a/dev-libs/libpqxx/libpqxx-2.5.1.ebuild b/dev-libs/libpqxx/libpqxx-2.5.1.ebuild
index b78f7d512d14..065c2e63c433 100644
--- a/dev-libs/libpqxx/libpqxx-2.5.1.ebuild
+++ b/dev-libs/libpqxx/libpqxx-2.5.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-2.5.1.ebuild,v 1.1 2005/05/09 00:35:13 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-2.5.1.ebuild,v 1.2 2005/05/09 20:34:02 nakano Exp $
+inherit eutils
IUSE=""
DESCRIPTION="C++ client API for PostgreSQL. The standard front-end for writing C++ programs that use PostgreSQL. Supersedes older libpq++ interface."
SRC_URI="ftp://gborg.postgresql.org/pub/libpqxx/stable/${P}.tar.gz
@@ -15,6 +16,7 @@ SLOT="0"
DEPEND="dev-db/libpq"
src_compile() {
+ epatch ${FILESDIR}/${P}-gentoo.patch
econf --enable-shared || die "./configure failed"
emake || die
}