summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-03 04:16:16 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-03 04:16:16 +0000
commit7affc3e237d56c4dd30547ba2a344c02a8633063 (patch)
tree6588472b92cab6765802c86906643874faa5ddf7 /dev-libs/libpeas
parentVersion bump. (diff)
downloadgentoo-2-7affc3e237d56c4dd30547ba2a344c02a8633063.tar.gz
gentoo-2-7affc3e237d56c4dd30547ba2a344c02a8633063.tar.bz2
gentoo-2-7affc3e237d56c4dd30547ba2a344c02a8633063.zip
Bump to 1.2.0 from the gnome overlay. Notable changes: optional gjs support, pygobject-3 compatibility.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libpeas')
-rw-r--r--dev-libs/libpeas/ChangeLog10
-rw-r--r--dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch57
-rw-r--r--dev-libs/libpeas/libpeas-1.2.0-r1.ebuild68
-rw-r--r--dev-libs/libpeas/metadata.xml4
4 files changed, 137 insertions, 2 deletions
diff --git a/dev-libs/libpeas/ChangeLog b/dev-libs/libpeas/ChangeLog
index d8e93f34fc98..a994092b8bea 100644
--- a/dev-libs/libpeas/ChangeLog
+++ b/dev-libs/libpeas/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libpeas
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/ChangeLog,v 1.1 2011/08/16 18:57:21 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/ChangeLog,v 1.2 2011/11/03 04:16:16 tetromino Exp $
+
+*libpeas-1.2.0-r1 (03 Nov 2011)
+
+ 03 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libpeas-1.2.0-r1.ebuild,
+ +files/libpeas-1.2.0-PeasPluginInfo-annotation.patch, metadata.xml:
+ Bump to 1.2.0 from the gnome overlay. Notable changes: optional gjs support,
+ pygobject-3 compatibility.
*libpeas-1.0.0 (16 Aug 2011)
diff --git a/dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch b/dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch
new file mode 100644
index 000000000000..3a2e9b4c88d8
--- /dev/null
+++ b/dev-libs/libpeas/files/libpeas-1.2.0-PeasPluginInfo-annotation.patch
@@ -0,0 +1,57 @@
+From afa50c526ce1aab53eff3c3373a97180fc90abe2 Mon Sep 17 00:00:00 2001
+From: Garrett Regier <garrettregier@gmail.com>
+Date: Thu, 29 Sep 2011 15:46:49 -0700
+Subject: [PATCH] Annotate PeasPluginInfo return values as transfer none
+
+Otherwise GObject-Introspection says that it is transfer full.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=660524
+---
+ libpeas-gtk/peas-gtk-plugin-manager-view.c | 2 +-
+ libpeas/peas-engine.c | 2 +-
+ libpeas/peas-extension-base.c | 3 ++-
+ 3 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/libpeas-gtk/peas-gtk-plugin-manager-view.c b/libpeas-gtk/peas-gtk-plugin-manager-view.c
+index 7eb7361..5f8f55f 100644
+--- a/libpeas-gtk/peas-gtk-plugin-manager-view.c
++++ b/libpeas-gtk/peas-gtk-plugin-manager-view.c
+@@ -952,7 +952,7 @@ peas_gtk_plugin_manager_view_set_selected_plugin (PeasGtkPluginManagerView *view
+ *
+ * Returns the currently selected plugin, or %NULL if a plugin is not selected.
+ *
+- * Returns: the selected plugin.
++ * Returns: (transfer none): the selected plugin.
+ */
+ PeasPluginInfo *
+ peas_gtk_plugin_manager_view_get_selected_plugin (PeasGtkPluginManagerView *view)
+diff --git a/libpeas/peas-engine.c b/libpeas/peas-engine.c
+index 1adf4ff..7b57d56 100644
+--- a/libpeas/peas-engine.c
++++ b/libpeas/peas-engine.c
+@@ -733,7 +733,7 @@ compare_plugin_info_and_name (PeasPluginInfo *info,
+ * Gets the #PeasPluginInfo corresponding with @plugin_name,
+ * or %NULL if @plugin_name was not found.
+ *
+- * Returns: the #PeasPluginInfo corresponding with
++ * Returns: (transfer none): the #PeasPluginInfo corresponding with
+ * a given plugin module name.
+ */
+ PeasPluginInfo *
+diff --git a/libpeas/peas-extension-base.c b/libpeas/peas-extension-base.c
+index 329a25f..7c4cba0 100644
+--- a/libpeas/peas-extension-base.c
++++ b/libpeas/peas-extension-base.c
+@@ -141,7 +141,8 @@ peas_extension_base_class_init (PeasExtensionBaseClass *klass)
+ *
+ * Get information relative to @extbase.
+ *
+- * Return value: the #PeasPluginInfo relative to the #PeasExtensionBase.
++ * Return value: (transfer none): the #PeasPluginInfo relative
++ * to the #PeasExtensionBase.
+ */
+ PeasPluginInfo *
+ peas_extension_base_get_plugin_info (PeasExtensionBase *extbase)
+--
+1.7.7.2
+
diff --git a/dev-libs/libpeas/libpeas-1.2.0-r1.ebuild b/dev-libs/libpeas/libpeas-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..52af3cc8ad08
--- /dev/null
+++ b/dev-libs/libpeas/libpeas-1.2.0-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpeas/libpeas-1.2.0-r1.ebuild,v 1.1 2011/11/03 04:16:16 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit eutils gnome2 python virtualx
+
+DESCRIPTION="A GObject plugins library"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc gjs +gtk glade +python seed vala"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.23.6:2
+ >=dev-libs/gobject-introspection-0.10.1
+ gjs? ( >=dev-libs/gjs-1.29.16 )
+ glade? ( >=dev-util/glade-3.9.1:3.10 )
+ gtk? ( >=x11-libs/gtk+-2.91.1:3[introspection] )
+ python? ( >=dev-python/pygobject-3.0.0:3 )
+ seed? ( >=dev-libs/seed-2.91.91 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ doc? ( >=dev-util/gtk-doc-1.11 )
+ vala? ( >=dev-lang/vala-0.11.1:0.12 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable gjs)
+ $(use_enable glade glade-catalog)
+ $(use_enable gtk)
+ $(use_enable python)
+ $(use_enable seed)
+ $(use_enable vala)
+ VALAC=$(type -P valac-0.12)
+ --disable-deprecation
+ --disable-static"
+ # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
+ # What do we do about gdb, valgrind, gcov, etc?
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Upstream patch to fix g-i annotations; prevents crashes
+ epatch "${FILESDIR}/${P}-PeasPluginInfo-annotation.patch"
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
+ # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
+ # To reproduce:
+ # >>> from gi.repository import Gtk
+ # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
+ # This should return True, it returns False for Xvfb
+ Xemake check
+}
diff --git a/dev-libs/libpeas/metadata.xml b/dev-libs/libpeas/metadata.xml
index 8bf7c930ef4d..87ac1eefb12d 100644
--- a/dev-libs/libpeas/metadata.xml
+++ b/dev-libs/libpeas/metadata.xml
@@ -3,12 +3,14 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
+ <flag name="gjs">Build support for loading JavaScript plugins using
+ <pkg>dev-libs/gjs</pkg></flag>
+ <flag name="glade">Install the glade catalog</flag>
<flag name="python">Build support for loading <pkg>dev-lang/python</pkg>
plugins</flag>
<flag name="seed">Build support for loading JavaScript plugins using
<pkg>dev-libs/seed</pkg></flag>
<flag name="vala">Build support for loading <pkg>dev-lang/vala</pkg>
plugins</flag>
- <flag name="glade">Install the glade catalog</flag>
</use>
</pkgmetadata>