summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-05-03 20:15:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-05-03 20:15:39 +0000
commit9fd0ac4d4536b0c1c1338bb7a5ebeeb465e0d73a (patch)
treea780fe1a85bfe0b285224f3ad3dc2c7b9cbad8b4 /dev-libs/libpcre
parentVersion bump KDE 4.4.3 (diff)
downloadgentoo-2-9fd0ac4d4536b0c1c1338bb7a5ebeeb465e0d73a.tar.gz
gentoo-2-9fd0ac4d4536b0c1c1338bb7a5ebeeb465e0d73a.tar.bz2
gentoo-2-9fd0ac4d4536b0c1c1338bb7a5ebeeb465e0d73a.zip
Bump for #311077
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/ChangeLog9
-rw-r--r--dev-libs/libpcre/libpcre-8.02.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-libs/libpcre/ChangeLog b/dev-libs/libpcre/ChangeLog
index 06c6cc4abe47..45526c23a5ab 100644
--- a/dev-libs/libpcre/ChangeLog
+++ b/dev-libs/libpcre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libpcre
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.163 2009/10/21 08:56:24 loki_val Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.164 2010/05/03 20:15:39 patrick Exp $
+
+*libpcre-8.02 (03 May 2010)
+
+ 03 May 2010; Patrick Lauer <patrick@gentoo.org> +libpcre-8.02.ebuild:
+ Bump for #311077
21 Oct 2009; Peter Alfredsen <loki_val@gentoo.org> -libpcre-7.8.ebuild,
-libpcre-7.8-r2.ebuild, libpcre-7.9-r1.ebuild, libpcre-8.00.ebuild:
diff --git a/dev-libs/libpcre/libpcre-8.02.ebuild b/dev-libs/libpcre/libpcre-8.02.ebuild
new file mode 100644
index 000000000000..e459214b42ec
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-8.02.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.02.ebuild,v 1.1 2010/05/03 20:15:39 patrick Exp $
+
+EAPI=2
+
+inherit libtool eutils toolchain-funcs
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+if [[ ${PV} == ${PV/_rc} ]]
+then
+ MY_P="pcre-${PV}"
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+else
+ MY_P="pcre-${PV/_rc/-RC}"
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
+fi
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 +cxx unicode zlib static-libs"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "s:libdir=@libdir@:libdir=/$(get_libdir):" libpcre.pc.in || die "Fixing libpcre pkgconfig files failed"
+ sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die "Fixing libpcrecpp pkgconfig files failed"
+}
+
+src_configure() {
+ econf --with-match-limit-recursion=8192 \
+ $(use_enable unicode utf8) $(use_enable unicode unicode-properties) \
+ $(use_enable cxx cpp) \
+ $(use_enable zlib pcregrep-libz) \
+ $(use_enable bzip2 pcregrep-libbz2) \
+ $(use_enable static-libs static) \
+ --enable-shared \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ gen_usr_ldscript -a pcre
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}
+
+pkg_postinst() {
+ elog "This version of ${PN} has stopped installing .la files. This may"
+ elog "cause compilation failures in other packages. To fix this problem,"
+ elog "install dev-util/lafilefixer and run:"
+ elog "lafilefixer --justfixit"
+}