summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-09 16:08:21 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-09 16:08:21 +0000
commit7bd3ab5f01fceef15aff29418f82e582f39a044a (patch)
tree2aeb85d6c184cfe8092f7894752b51873b0146f8 /dev-libs/libpcre
parentMarking wireshark-1.0.7 ppc64 and ppc for bug 264571 (diff)
downloadgentoo-2-7bd3ab5f01fceef15aff29418f82e582f39a044a.tar.gz
gentoo-2-7bd3ab5f01fceef15aff29418f82e582f39a044a.tar.bz2
gentoo-2-7bd3ab5f01fceef15aff29418f82e582f39a044a.zip
Bump. No longer include .la and .a files. Revision bump for 7.8 with the same changes. Move libpcre.so* to /lib for grep - bug 1638 and bug 53627.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/ChangeLog12
-rw-r--r--dev-libs/libpcre/libpcre-7.7-r1.ebuild52
-rw-r--r--dev-libs/libpcre/libpcre-7.8-r1.ebuild60
-rw-r--r--dev-libs/libpcre/libpcre-7.9_rc2.ebuild60
4 files changed, 130 insertions, 54 deletions
diff --git a/dev-libs/libpcre/ChangeLog b/dev-libs/libpcre/ChangeLog
index 430e1c1e6abe..3cc409c0bce4 100644
--- a/dev-libs/libpcre/ChangeLog
+++ b/dev-libs/libpcre/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libpcre
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.146 2008/11/05 11:42:25 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.147 2009/04/09 16:08:21 loki_val Exp $
+
+*libpcre-7.9_rc2 (09 Apr 2009)
+*libpcre-7.8-r1 (09 Apr 2009)
+
+ 09 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> -libpcre-7.7-r1.ebuild,
+ +libpcre-7.8-r1.ebuild, +libpcre-7.9_rc2.ebuild:
+ Bump. No longer include .la and .a files. Revision bump for 7.8 with the
+ same changes. Move libpcre.so* to /lib for grep - bug 1638 and bug 53627.
05 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> -libpcre-7.4.ebuild:
Clean out GLSA'd ebuild
diff --git a/dev-libs/libpcre/libpcre-7.7-r1.ebuild b/dev-libs/libpcre/libpcre-7.7-r1.ebuild
deleted file mode 100644
index 211016610570..000000000000
--- a/dev-libs/libpcre/libpcre-7.7-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-7.7-r1.ebuild,v 1.2 2008/11/05 00:33:31 vapier Exp $
-
-EAPI=1
-
-inherit libtool eutils
-
-MY_P="pcre-${PV}"
-
-DESCRIPTION="Perl-compatible regular expression library"
-HOMEPAGE="http://www.pcre.org/"
-SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="bzip2 +cxx doc unicode zlib"
-
-DEPEND="dev-util/pkgconfig"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-buffer-overflow.patch
- elibtoolize
-}
-
-src_compile() {
- # Enable building of static libs too - grep and others
- # depend on them being built: bug 164099
- econf --with-match-limit-recursion=8192 \
- $(use_enable unicode utf8) $(use_enable unicode unicode-properties) \
- $(use_enable cxx cpp) \
- $(use_enable zlib pcregrep-libz) \
- $(use_enable bzip2 pcregrep-libbz2) \
- --enable-static \
- --htmldir=/usr/share/doc/${PF}/html \
- --docdir=/usr/share/doc/${PF} \
- || die "econf failed"
- emake all || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc doc/*.txt AUTHORS
- use doc && dohtml doc/html/*
-}
diff --git a/dev-libs/libpcre/libpcre-7.8-r1.ebuild b/dev-libs/libpcre/libpcre-7.8-r1.ebuild
new file mode 100644
index 000000000000..64885d9e7240
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-7.8-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-7.8-r1.ebuild,v 1.1 2009/04/09 16:08:21 loki_val Exp $
+
+EAPI=2
+
+inherit libtool eutils
+
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+if [[ ${PV} == ${PV/_rc} ]]
+then
+ MY_P="pcre-${PV}"
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+else
+ MY_P="pcre-${PV/_rc/-RC}"
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
+fi
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 +cxx doc unicode zlib"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "s:libdir=@libdir@:libdir=/$(get_libdir):" libpcre.pc.in || die "Fixing libpcre pkgconfig files failed"
+ sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die "Fixing libpcrecpp pkgconfig files failed"
+ echo "Requires: libpcre = @PACKAGE_VERSION@" >> libpcrecpp.pc.in
+ elibtoolize
+}
+
+src_configure() {
+ econf --with-match-limit-recursion=8192 \
+ $(use_enable unicode utf8) $(use_enable unicode unicode-properties) \
+ $(use_enable cxx cpp) \
+ $(use_enable zlib pcregrep-libz) \
+ $(use_enable bzip2 pcregrep-libbz2) \
+ --disable-static \
+ --enable-shared \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libpcre.so* "${D}"/$(get_libdir)/ || die "moving libpcre failed"
+ dosym ../../$(get_libdir)/$(readlink "${D}"/$(get_libdir)/libpcre.so) /usr/$(get_libdir)/libpcre.so || die "Creating symlink failed"
+
+ dodoc doc/*.txt AUTHORS
+ use doc && dohtml doc/html/*
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}
diff --git a/dev-libs/libpcre/libpcre-7.9_rc2.ebuild b/dev-libs/libpcre/libpcre-7.9_rc2.ebuild
new file mode 100644
index 000000000000..379c3e117bb7
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-7.9_rc2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-7.9_rc2.ebuild,v 1.1 2009/04/09 16:08:21 loki_val Exp $
+
+EAPI=2
+
+inherit libtool eutils
+
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+if [[ ${PV} == ${PV/_rc} ]]
+then
+ MY_P="pcre-${PV}"
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+else
+ MY_P="pcre-${PV/_rc/-RC}"
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
+fi
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 +cxx doc unicode zlib"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "s:libdir=@libdir@:libdir=/$(get_libdir):" libpcre.pc.in || die "Fixing libpcre pkgconfig files failed"
+ sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die "Fixing libpcrecpp pkgconfig files failed"
+ echo "Requires: libpcre = @PACKAGE_VERSION@" >> libpcrecpp.pc.in
+ elibtoolize
+}
+
+src_configure() {
+ econf --with-match-limit-recursion=8192 \
+ $(use_enable unicode utf8) $(use_enable unicode unicode-properties) \
+ $(use_enable cxx cpp) \
+ $(use_enable zlib pcregrep-libz) \
+ $(use_enable bzip2 pcregrep-libbz2) \
+ --disable-static \
+ --enable-shared \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libpcre.so* "${D}"/$(get_libdir)/ || die "moving libpcre failed"
+ dosym ../../$(get_libdir)/$(readlink "${D}"/$(get_libdir)/libpcre.so) /usr/$(get_libdir)/libpcre.so || die "Creating symlink failed"
+
+ dodoc doc/*.txt AUTHORS
+ use doc && dohtml doc/html/*
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}