summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-02 02:43:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-02 02:43:36 +0000
commit5f62102ec93100c96ae08e8d47386c45c918cf87 (patch)
tree02c205063760c88f6a26dc44bd8cc074dd34fafb /dev-libs/libpcre
parentInitial version from Phil's maintainership. (diff)
downloadgentoo-2-5f62102ec93100c96ae08e8d47386c45c918cf87.tar.gz
gentoo-2-5f62102ec93100c96ae08e8d47386c45c918cf87.tar.bz2
gentoo-2-5f62102ec93100c96ae08e8d47386c45c918cf87.zip
Version bump.
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-libs/libpcre')
-rw-r--r--dev-libs/libpcre/ChangeLog7
-rw-r--r--dev-libs/libpcre/libpcre-8.32.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-libs/libpcre/ChangeLog b/dev-libs/libpcre/ChangeLog
index f292bf9253c9..84bd9b410adf 100644
--- a/dev-libs/libpcre/ChangeLog
+++ b/dev-libs/libpcre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libpcre
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.207 2012/07/12 11:05:15 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.208 2012/12/02 02:43:36 flameeyes Exp $
+
+*libpcre-8.32 (02 Dec 2012)
+
+ 02 Dec 2012; Diego E. Pettenò <flameeyes@gentoo.org> +libpcre-8.32.ebuild:
+ Version bump.
12 Jul 2012; Fabian Groffen <grobian@gentoo.org>
+files/libpcre-8.31-madvise.patch, libpcre-8.31.ebuild:
diff --git a/dev-libs/libpcre/libpcre-8.32.ebuild b/dev-libs/libpcre/libpcre-8.32.ebuild
new file mode 100644
index 000000000000..d79cee3b8d7c
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-8.32.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.32.ebuild,v 1.1 2012/12/02 02:43:36 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils multilib libtool flag-o-matic toolchain-funcs
+
+DESCRIPTION="Perl-compatible regular expression library"
+HOMEPAGE="http://www.pcre.org/"
+MY_P="pcre-${PV/_rc/-RC}"
+if [[ ${PV} != *_rc* ]] ; then
+ # Only the final releases are available here.
+ SRC_URI="mirror://sourceforge/pcre/${MY_P}.tar.bz2
+ ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
+else
+ SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
+fi
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 +cxx +jit libedit pcre16 +readline +recursion-limit static-libs unicode zlib"
+REQUIRED_USE="readline? ( !libedit )
+ libedit? ( !readline )"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )
+ libedit? ( dev-libs/libedit )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ userland_GNU? ( >=sys-apps/findutils-4.4.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die
+ elibtoolize
+}
+
+src_configure() {
+ [[ ${CHOST} == *-mint* ]] && append-cppflags -D_GNU_SOURCE
+ econf \
+ --with-match-limit-recursion=$(usex recursion-limit 8192 MATCH_LIMIT) \
+ $(use_enable bzip2 pcregrep-libbz2) \
+ $(use_enable cxx cpp) \
+ $(use_enable jit) $(use_enable jit pcregrep-jit) \
+ $(use_enable pcre16) \
+ $(use_enable libedit pcretest-libedit) \
+ $(use_enable readline pcretest-libreadline) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode utf) $(use_enable unicode unicode-properties) \
+ $(use_enable zlib pcregrep-libz) \
+ --enable-pcre8 \
+ --enable-shared \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ gen_usr_ldscript -a pcre
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ preserve_old_lib /$(get_libdir)/libpcre.so.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/libpcre.so.0
+}