summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-27 11:16:42 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-27 11:16:42 +0000
commit5b04cd50f6b34e3111f756f852f15101cfc681e6 (patch)
treeeca5d0558286e180969b50a93282d28a7562d89d /dev-libs/libpcre/libpcre-3.9-r1.ebuild
parentUngzipped HTML documentation (diff)
downloadgentoo-2-5b04cd50f6b34e3111f756f852f15101cfc681e6.tar.gz
gentoo-2-5b04cd50f6b34e3111f756f852f15101cfc681e6.tar.bz2
gentoo-2-5b04cd50f6b34e3111f756f852f15101cfc681e6.zip
Ungzipped HTML docs, and removed obsolete ebuilds
Diffstat (limited to 'dev-libs/libpcre/libpcre-3.9-r1.ebuild')
-rw-r--r--dev-libs/libpcre/libpcre-3.9-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libpcre/libpcre-3.9-r1.ebuild b/dev-libs/libpcre/libpcre-3.9-r1.ebuild
new file mode 100644
index 000000000000..014597eecd87
--- /dev/null
+++ b/dev-libs/libpcre/libpcre-3.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Claes Nästen <pekdon@gmx.net>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.9 2001/10/21 16:17:12 agriffis Exp
+
+S=${WORKDIR}/pcre-${PV}
+DESCRIPTION="Perl-compitable regular expression library"
+SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-${PV}.tar.bz2"
+HOMEPAGE="http://www.pcre.org/"
+
+DEPEND="virtual/glibc"
+SLOT="3"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING INSTALL LICENCE NON-UNIX-USE
+ dodoc doc/*.txt
+ dodoc doc/Tech.Notes
+ dohtml -r doc
+}