summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-02-19 15:11:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-02-19 15:11:03 +0000
commit4d66a57faa2ded71b64736c6d058cada3680506f (patch)
tree065c76e024cc1cf0febfc2ceff8b9ac1c41fe6a8 /dev-libs/libots/libots-2.2.7-r2.ebuild
parentmarked ~alpha (Manifest recommit) (diff)
downloadgentoo-2-4d66a57faa2ded71b64736c6d058cada3680506f.tar.gz
gentoo-2-4d66a57faa2ded71b64736c6d058cada3680506f.tar.bz2
gentoo-2-4d66a57faa2ded71b64736c6d058cada3680506f.zip
use rpm.eclass instead of rpm2targz, and doins/dolib/etc instead of cp
Diffstat (limited to 'dev-libs/libots/libots-2.2.7-r2.ebuild')
-rw-r--r--dev-libs/libots/libots-2.2.7-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libots/libots-2.2.7-r2.ebuild b/dev-libs/libots/libots-2.2.7-r2.ebuild
new file mode 100644
index 000000000000..4e86416e8b39
--- /dev/null
+++ b/dev-libs/libots/libots-2.2.7-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libots/libots-2.2.7-r2.ebuild,v 1.1 2004/02/19 15:11:03 taviso Exp $
+
+inherit eutils rpm
+
+At="libots-2.2.7-2.alpha.rpm"
+HOMEPAGE="http://www.support.compaq.com/alpha-tools/"
+DESCRIPTION="Compaq Linux optimized runtime for Alpha/Linux/GNU"
+SRC_URI="ftp://ftp.compaq.com/pub/products/linuxdevtools/latest/${At}"
+
+DEPEND="virtual/glibc"
+LICENSE="compaq-sdla"
+SLOT="2.2.7"
+KEYWORDS="-* ~alpha"
+
+S=${WORKDIR}/usr/lib/compaq/libots-2.2.7
+
+RESTRICT="nostrip"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_install () {
+ into /
+ dolib.so libots.so
+ dolib.a libots.a
+
+ dodoc README
+}