summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-05-27 00:09:45 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-05-27 00:09:45 +0000
commit61600aba50c98d703eae44b9042a716cfc91dfd0 (patch)
treeb54ea4d1e4663b487522958ec4eb4a4f24c9096e /dev-libs/libotf
parentgegl: remove deprecated usage of img_convert-function from ffmpeg (diff)
downloadgentoo-2-61600aba50c98d703eae44b9042a716cfc91dfd0.tar.gz
gentoo-2-61600aba50c98d703eae44b9042a716cfc91dfd0.tar.bz2
gentoo-2-61600aba50c98d703eae44b9042a716cfc91dfd0.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libotf')
-rw-r--r--dev-libs/libotf/ChangeLog9
-rw-r--r--dev-libs/libotf/libotf-0.9.9.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-libs/libotf/ChangeLog b/dev-libs/libotf/ChangeLog
index 7433fdff1897..7ff6993c6e39 100644
--- a/dev-libs/libotf/ChangeLog
+++ b/dev-libs/libotf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libotf
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/ChangeLog,v 1.40 2009/04/05 18:52:26 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/ChangeLog,v 1.41 2009/05/27 00:09:45 matsuu Exp $
+
+*libotf-0.9.9 (27 May 2009)
+
+ 27 May 2009; MATSUU Takuto <matsuu@gentoo.org> +libotf-0.9.9.ebuild:
+ Version bumped.
05 Apr 2009; Raúl Porcel <armin76@gentoo.org> libotf-0.9.8.ebuild:
Add ~sh
diff --git a/dev-libs/libotf/libotf-0.9.9.ebuild b/dev-libs/libotf/libotf-0.9.9.ebuild
new file mode 100644
index 000000000000..46114e727301
--- /dev/null
+++ b/dev-libs/libotf/libotf-0.9.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.9.ebuild,v 1.1 2009/05/27 00:09:45 matsuu Exp $
+
+inherit autotools
+
+DESCRIPTION="Library for handling OpenType fonts (OTF)"
+HOMEPAGE="http://www.m17n.org/libotf/"
+SRC_URI="http://www.m17n.org/libotf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="X"
+
+RDEPEND=">=media-libs/freetype-2.1
+ X? (
+ x11-libs/libXaw
+ x11-libs/libICE
+ )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use X ; then
+ sed -i -e '/^bin_PROGRAMS/s/otfview//' example/Makefile.am || die
+ eautoreconf
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS NEWS README ChangeLog
+}