summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 06:34:03 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 06:34:03 +0000
commit4285a86ee77e91ef17f43755f015c6a2b6cdade5 (patch)
tree6c4a448c395d03df228f0346193a6ffff8c31ca0 /dev-libs/libotf
parentold (diff)
downloadgentoo-2-4285a86ee77e91ef17f43755f015c6a2b6cdade5.tar.gz
gentoo-2-4285a86ee77e91ef17f43755f015c6a2b6cdade5.tar.bz2
gentoo-2-4285a86ee77e91ef17f43755f015c6a2b6cdade5.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'dev-libs/libotf')
-rw-r--r--dev-libs/libotf/ChangeLog8
-rw-r--r--dev-libs/libotf/libotf-0.9.4.ebuild9
-rw-r--r--dev-libs/libotf/libotf-0.9.5.ebuild9
-rw-r--r--dev-libs/libotf/libotf-0.9.6.ebuild9
-rw-r--r--dev-libs/libotf/libotf-0.9.7.ebuild9
5 files changed, 35 insertions, 9 deletions
diff --git a/dev-libs/libotf/ChangeLog b/dev-libs/libotf/ChangeLog
index 9a1b69959917..f9f7b3c7f3ba 100644
--- a/dev-libs/libotf/ChangeLog
+++ b/dev-libs/libotf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libotf
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/ChangeLog,v 1.35 2008/02/11 16:52:08 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/ChangeLog,v 1.36 2008/06/15 06:34:03 zmedico Exp $
+
+ 15 Jun 2008; Zac Medico <zmedico@gentoo.org> libotf-0.9.4.ebuild,
+ libotf-0.9.5.ebuild, libotf-0.9.6.ebuild, libotf-0.9.7.ebuild:
+ Bug #226505 - For compatibility with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
11 Feb 2008; Christoph Mende <angelos@gentoo.org> libotf-0.9.6.ebuild:
Stable on amd64, bug #205218
diff --git a/dev-libs/libotf/libotf-0.9.4.ebuild b/dev-libs/libotf/libotf-0.9.4.ebuild
index 1a1fd4437d4e..dc127a49931d 100644
--- a/dev-libs/libotf/libotf-0.9.4.ebuild
+++ b/dev-libs/libotf/libotf-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.4.ebuild,v 1.3 2008/02/02 22:19:32 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.4.ebuild,v 1.4 2008/06/15 06:34:03 zmedico Exp $
DESCRIPTION="Library for handling OpenType fonts (OTF)"
HOMEPAGE="http://www.m17n.org/libotf/"
@@ -31,8 +31,13 @@ src_install() {
dodoc AUTHORS INSTALL NEWS README ChangeLog
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.9.3"
+ previous_less_than_0_9_3=$?
+}
+
pkg_postinst() {
- if has_version '<dev-libs/libotf-0.9.3' ; then
+ if [[ $previous_less_than_0_9_3 = 0 ]] ; then
ewarn
ewarn "Shared library extension has been changed. You may need to recompile"
diff --git a/dev-libs/libotf/libotf-0.9.5.ebuild b/dev-libs/libotf/libotf-0.9.5.ebuild
index 24afa39de029..d95d76d4defe 100644
--- a/dev-libs/libotf/libotf-0.9.5.ebuild
+++ b/dev-libs/libotf/libotf-0.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.5.ebuild,v 1.2 2008/02/02 22:19:32 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.5.ebuild,v 1.3 2008/06/15 06:34:03 zmedico Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -38,8 +38,13 @@ src_install() {
dodoc AUTHORS INSTALL NEWS README ChangeLog
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.9.3"
+ previous_less_than_0_9_3=$?
+}
+
pkg_postinst() {
- if has_version '<dev-libs/libotf-0.9.3' ; then
+ if [[ $previous_less_than_0_9_3 = 0 ]] ; then
ewarn
ewarn "Shared library extension has been changed. You may need to recompile"
ewarn "everything depending on this library (in short, please remerge m17n-lib"
diff --git a/dev-libs/libotf/libotf-0.9.6.ebuild b/dev-libs/libotf/libotf-0.9.6.ebuild
index be10fd278591..1a3232c3d082 100644
--- a/dev-libs/libotf/libotf-0.9.6.ebuild
+++ b/dev-libs/libotf/libotf-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.6.ebuild,v 1.8 2008/02/11 16:52:08 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.6.ebuild,v 1.9 2008/06/15 06:34:03 zmedico Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -39,8 +39,13 @@ src_install() {
dodoc AUTHORS NEWS README ChangeLog
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.9.3"
+ previous_less_than_0_9_3=$?
+}
+
pkg_postinst() {
- if has_version '<dev-libs/libotf-0.9.3' ; then
+ if [[ $previous_less_than_0_9_3 = 0 ]] ; then
ewarn
ewarn "Shared library extension has been changed. You may need to recompile"
ewarn "everything depending on this library (in short, please remerge m17n-lib"
diff --git a/dev-libs/libotf/libotf-0.9.7.ebuild b/dev-libs/libotf/libotf-0.9.7.ebuild
index 5404d744fd40..dcdfa5cd7739 100644
--- a/dev-libs/libotf/libotf-0.9.7.ebuild
+++ b/dev-libs/libotf/libotf-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.7.ebuild,v 1.3 2008/02/02 22:19:32 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.7.ebuild,v 1.4 2008/06/15 06:34:03 zmedico Exp $
WANT_AUTOMAKE=latest
WANT_AUTOCONF=latest
@@ -39,8 +39,13 @@ src_install() {
dodoc AUTHORS NEWS README ChangeLog
}
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.9.3"
+ previous_less_than_0_9_3=$?
+}
+
pkg_postinst() {
- if has_version '<dev-libs/libotf-0.9.3' ; then
+ if [[ $previous_less_than_0_9_3 = 0 ]] ; then
ewarn
ewarn "Shared library extension has been changed. You may need to recompile"
ewarn "everything depending on this library (in short, please remerge m17n-lib"