summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-02-17 15:35:38 +0000
committerMike Auty <ikelos@gentoo.org>2010-02-17 15:35:38 +0000
commit4a9524602010c58c2fda62b875b4710ddbc51580 (patch)
tree51d606716727b02a557c21ca38076051c13a4cb6 /dev-libs/libnfc
parentMasking smoke-4.3 and kdebindings-csharp-4.3 wrt bug 295573 (diff)
downloadgentoo-2-4a9524602010c58c2fda62b875b4710ddbc51580.tar.gz
gentoo-2-4a9524602010c58c2fda62b875b4710ddbc51580.tar.bz2
gentoo-2-4a9524602010c58c2fda62b875b4710ddbc51580.zip
Version bump libnfc to 1.3.3.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libnfc')
-rw-r--r--dev-libs/libnfc/ChangeLog7
-rw-r--r--dev-libs/libnfc/libnfc-1.3.3.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libnfc/ChangeLog b/dev-libs/libnfc/ChangeLog
index abb790238a2e..f1b29d5b7b4f 100644
--- a/dev-libs/libnfc/ChangeLog
+++ b/dev-libs/libnfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnfc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.3 2010/02/01 11:23:06 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.4 2010/02/17 15:35:38 ikelos Exp $
+
+*libnfc-1.3.3 (17 Feb 2010)
+
+ 17 Feb 2010; Mike Auty <ikelos@gentoo.org> +libnfc-1.3.3.ebuild:
+ Version bump libnfc to 1.3.3.
*libnfc-1.3.2 (01 Feb 2010)
diff --git a/dev-libs/libnfc/libnfc-1.3.3.ebuild b/dev-libs/libnfc/libnfc-1.3.3.ebuild
new file mode 100644
index 000000000000..66202c90ace8
--- /dev/null
+++ b/dev-libs/libnfc/libnfc-1.3.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/libnfc-1.3.3.ebuild,v 1.1 2010/02/17 15:35:38 ikelos Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Near Field Communications (NFC) library"
+HOMEPAGE="http://www.libnfc.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+CDEPEND="sys-apps/pcsc-lite
+ dev-libs/libusb"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+src_compile() {
+ emake || die "Failed to compile."
+ use doc && doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install properly."
+ use doc && dohtml "${S}"/doc/html/*
+}