summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-02-09 05:18:43 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-02-09 05:18:43 +0000
commit059d14532a6c3f60e09d76c4d2990bc63b296a84 (patch)
tree1de91a4321f7f90762fc09934ae21ac3584ba752 /dev-libs/libmemcached
parentmasking >=syslinux-6 due to compile failure with hardened toolchain (diff)
downloadgentoo-2-059d14532a6c3f60e09d76c4d2990bc63b296a84.tar.gz
gentoo-2-059d14532a6c3f60e09d76c4d2990bc63b296a84.tar.bz2
gentoo-2-059d14532a6c3f60e09d76c4d2990bc63b296a84.zip
fixes for bug 498250 and restricting tests for bug 430126
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-libs/libmemcached')
-rw-r--r--dev-libs/libmemcached/ChangeLog9
-rw-r--r--dev-libs/libmemcached/libmemcached-1.0.17-r3.ebuild (renamed from dev-libs/libmemcached/libmemcached-1.0.17-r2.ebuild)5
-rw-r--r--dev-libs/libmemcached/libmemcached-1.0.17.ebuild43
3 files changed, 11 insertions, 46 deletions
diff --git a/dev-libs/libmemcached/ChangeLog b/dev-libs/libmemcached/ChangeLog
index 8b250d2fccd9..ee0eb649b375 100644
--- a/dev-libs/libmemcached/ChangeLog
+++ b/dev-libs/libmemcached/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libmemcached
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.68 2014/01/27 15:43:30 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/ChangeLog,v 1.69 2014/02/09 05:18:43 prometheanfire Exp $
+
+*libmemcached-1.0.17-r3 (09 Feb 2014)
+
+ 09 Feb 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +libmemcached-1.0.17-r3.ebuild, -libmemcached-1.0.17-r2.ebuild,
+ -libmemcached-1.0.17.ebuild:
+ fixes for bug 498250 and restricting tests for bug 430126
*libmemcached-1.0.17-r2 (27 Jan 2014)
diff --git a/dev-libs/libmemcached/libmemcached-1.0.17-r2.ebuild b/dev-libs/libmemcached/libmemcached-1.0.17-r3.ebuild
index c5dc61b595bf..cc0d8608f458 100644
--- a/dev-libs/libmemcached/libmemcached-1.0.17-r2.ebuild
+++ b/dev-libs/libmemcached/libmemcached-1.0.17-r3.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-1.0.17-r2.ebuild,v 1.1 2014/01/27 15:43:30 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-1.0.17-r3.ebuild,v 1.1 2014/02/09 05:18:43 prometheanfire Exp $
EAPI=5
inherit eutils multilib
+RESTRICT="test" # https://bugs.gentoo.org/show_bug.cgi?id=498250 https://bugs.launchpad.net/gentoo/+bug/1278023
DESCRIPTION="a C client library to the memcached server"
HOMEPAGE="http://libmemcached.org/libMemcached.html"
@@ -16,7 +17,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd
IUSE="debug hsieh +libevent sasl static-libs"
DEPEND="net-misc/memcached
- dev-libs/cyrus-sasl
+ sasl? ( dev-libs/cyrus-sasl )
libevent? ( dev-libs/libevent )"
RDEPEND="${DEPEND}"
diff --git a/dev-libs/libmemcached/libmemcached-1.0.17.ebuild b/dev-libs/libmemcached/libmemcached-1.0.17.ebuild
deleted file mode 100644
index 7fc52d354768..000000000000
--- a/dev-libs/libmemcached/libmemcached-1.0.17.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-1.0.17.ebuild,v 1.1 2013/11/02 18:09:34 robbat2 Exp $
-
-EAPI="4"
-
-inherit eutils multilib
-
-DESCRIPTION="a C client library to the memcached server"
-HOMEPAGE="http://libmemcached.org/libMemcached.html"
-SRC_URI="http://launchpad.net/${PN}/1.0/${PV}/+download/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug hsieh +libevent static-libs"
-
-DEPEND="net-misc/memcached
- dev-libs/cyrus-sasl
- libevent? ( dev-libs/libevent )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- econf \
- --disable-dtrace \
- $(use_enable static-libs static) \
- $(use_enable sasl sasl) \
- $(use_enable debug debug) \
- $(use_enable debug assert) \
- $(use_enable hsieh hsieh_hash) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib*.la
-
- dodoc AUTHORS ChangeLog README THANKS TODO
- # remove manpage to avoid collision, see bug #299330
- rm -f "${D}"/usr/share/man/man1/memdump.*
- newman man/memdump.1 memcached_memdump.1
-}