summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-15 21:00:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-15 21:00:17 +0000
commit93649aefe831d388def757b1a4af59fd914a86b4 (patch)
tree851d12a17c19eccd6a8a2aed4d9ecc6faa7df28c /dev-libs/libmcrypt
parentStable on alpha, bug #250928 (diff)
downloadgentoo-2-93649aefe831d388def757b1a4af59fd914a86b4.tar.gz
gentoo-2-93649aefe831d388def757b1a4af59fd914a86b4.tar.bz2
gentoo-2-93649aefe831d388def757b1a4af59fd914a86b4.zip
Bug #132356 - fix rotations that bit alpha. In ~arch for mass testing to avoid breakage issues.
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'dev-libs/libmcrypt')
-rw-r--r--dev-libs/libmcrypt/ChangeLog11
-rw-r--r--dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch18
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r1.ebuild32
3 files changed, 59 insertions, 2 deletions
diff --git a/dev-libs/libmcrypt/ChangeLog b/dev-libs/libmcrypt/ChangeLog
index c9401c9f7027..1a8912b93716 100644
--- a/dev-libs/libmcrypt/ChangeLog
+++ b/dev-libs/libmcrypt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libmcrypt
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/ChangeLog,v 1.44 2007/12/11 13:38:58 alonbl Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/ChangeLog,v 1.45 2008/12/15 21:00:17 robbat2 Exp $
+
+*libmcrypt-2.5.8-r1 (15 Dec 2008)
+
+ 15 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libmcrypt-2.5.8-rotate-mask.patch, +libmcrypt-2.5.8-r1.ebuild:
+ Bug #132356 - fix rotations that bit alpha. In ~arch for mass testing to
+ avoid breakage issues.
11 Dec 2007; Alon Bar-Lev <alonbl@gentoo.org>
-files/libmcrypt-2.5.7-m4.patch, -libmcrypt-2.5.7.ebuild,
diff --git a/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
new file mode 100644
index 000000000000..ca31df4b2719
--- /dev/null
+++ b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
@@ -0,0 +1,18 @@
+--- KNOWN-BUGS 2008-12-13 15:31:49.000000000 -0500
++++ /dev/null 2008-12-13 02:05:21.751517562 -0500
+@@ -1 +0,0 @@
+-- cast-256 and rc6 do not work properly on Alpha (64 bit) machines
+--- lib/mcrypt_modules.h.orig 2008-12-13 15:33:06.000000000 -0500
++++ lib/mcrypt_modules.h 2008-12-13 15:25:01.000000000 -0500
+@@ -1,7 +1,7 @@
+-#define rotl32(x,n) (((x) << ((word32)(n))) | ((x) >> (32 - (word32)(n))))
+-#define rotr32(x,n) (((x) >> ((word32)(n))) | ((x) << (32 - (word32)(n))))
+-#define rotl16(x,n) (((x) << ((word16)(n))) | ((x) >> (16 - (word16)(n))))
+-#define rotr16(x,n) (((x) >> ((word16)(n))) | ((x) << (16 - (word16)(n))))
++#define rotl32(x,n) (((x) << ((word32)(n & 31))) | ((x) >> (32 - (word32)(n & 31))))
++#define rotr32(x,n) (((x) >> ((word32)(n & 31))) | ((x) << (32 - (word32)(n & 31))))
++#define rotl16(x,n) (((x) << ((word16)(n & 15))) | ((x) >> (16 - (word16)(n & 15))))
++#define rotr16(x,n) (((x) >> ((word16)(n & 15))) | ((x) << (16 - (word16)(n & 15))))
+
+ /* Use hardware rotations.. when available */
+ #ifdef swap32
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r1.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r1.ebuild
new file mode 100644
index 000000000000..ae0a0aadd84e
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.8-r1.ebuild,v 1.1 2008/12/15 21:00:17 robbat2 Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/$P-rotate-mask.patch
+ # freebsd?
+ elibtoolize
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failure"
+
+ dodoc AUTHORS KNOWN-BUGS INSTALL NEWS README THANKS TODO ChangeLog
+ dodoc doc/README.* doc/example.c
+ prepalldocs
+}