summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-30 22:04:52 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-30 22:04:52 +0000
commit56a5f9195082283b1cab9ef9a0692c06182eadcc (patch)
tree738b3afb235c60a814418b2b3175f0839d6411d3 /dev-libs/libmcrypt
parentsome syntax changes (diff)
downloadgentoo-2-56a5f9195082283b1cab9ef9a0692c06182eadcc.tar.gz
gentoo-2-56a5f9195082283b1cab9ef9a0692c06182eadcc.tar.bz2
gentoo-2-56a5f9195082283b1cab9ef9a0692c06182eadcc.zip
syntax changes
Diffstat (limited to 'dev-libs/libmcrypt')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.1-r3.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.1-r3.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.1-r3.ebuild
index ae9442774441..61206eed4c86 100644
--- a/dev-libs/libmcrypt/libmcrypt-2.5.1-r3.ebuild
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.1-r3.ebuild,v 1.3 2002/06/30 20:45:12 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.1-r3.ebuild,v 1.4 2002/06/30 22:04:52 azarah Exp $
inherit libtool
@@ -21,19 +21,29 @@ src_unpack() {
unpack ${A}
cd ${S}
+ # This is also fixes for bug #3940. The included libltdl gives some
+ # errors during ./configure
rm -rf ${S}/libltdl
rm -f ${S}/config.{guess,status,sub}
libtoolize --ltdl --copy --force
- # Try to fix some wierd build problems.
+ # Try to fix some wierd build problems. See bug #3940.
+ echo ">>> Reconfiguring package..."
for x in $(find ${S} -name configure)
do
cd ${x%/*}
export WANT_AUTOMAKE_1_6=1
export WANT_AUTOCONF_2_5=1
- aclocal
- automake --gnu --add-missing --include-deps
- autoconf
+ autoreconf --force --install --symlink &>${T}/autoreconf.log || ( \
+ echo "DEBUG: working directory is: `pwd`" >>${T}/autoreconf.log
+ eerror "Reonfigure failed, please attatch the contents of:"
+ eerror
+ eerror " ${T}/autoreconf.log"
+ eerror
+ eerror "in your bugreport."
+ # we need an error here, else the ebuild do not die
+ exit 1
+ ) || die "running autoreconf failed"
done
}