summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2010-09-29 02:26:02 +0000
committerSteve Arnold <nerdboy@gentoo.org>2010-09-29 02:26:02 +0000
commit48d0279ec31309a2d5a7fdfdaa22a676009d3e55 (patch)
tree378292bb6cc9ea940f8ed4647e4af89573397220 /dev-libs/liblist
parentAdd xz on sci-electronics/gtkwave to p.use.mask (diff)
downloadgentoo-2-48d0279ec31309a2d5a7fdfdaa22a676009d3e55.tar.gz
gentoo-2-48d0279ec31309a2d5a7fdfdaa22a676009d3e55.tar.bz2
gentoo-2-48d0279ec31309a2d5a7fdfdaa22a676009d3e55.zip
Really removing old versions...
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/liblist')
-rw-r--r--dev-libs/liblist/ChangeLog6
-rw-r--r--dev-libs/liblist/files/liblist-2.1-sharedlib.patch57
-rw-r--r--dev-libs/liblist/liblist-2.1-r1.ebuild61
-rw-r--r--dev-libs/liblist/liblist-2.1.ebuild58
4 files changed, 5 insertions, 177 deletions
diff --git a/dev-libs/liblist/ChangeLog b/dev-libs/liblist/ChangeLog
index 368a58415ee9..8626ea52ea28 100644
--- a/dev-libs/liblist/ChangeLog
+++ b/dev-libs/liblist/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/liblist
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/ChangeLog,v 1.6 2010/09/29 02:21:45 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/ChangeLog,v 1.7 2010/09/29 02:26:01 nerdboy Exp $
+
+ 29 Sep 2010; Steve Arnold <nerdboy@gentoo.org> -liblist-2.1.ebuild,
+ -liblist-2.1-r1.ebuild, -files/liblist-2.1-sharedlib.patch:
+ This time I'm *really* removing the old versions...
29 Sep 2010; Steve Arnold <nerdboy@gentoo.org> liblist-2.3.1-r1.ebuild:
Added upstream patch and cleaned up docdir confusion. Also removed old
diff --git a/dev-libs/liblist/files/liblist-2.1-sharedlib.patch b/dev-libs/liblist/files/liblist-2.1-sharedlib.patch
deleted file mode 100644
index 49dec2c93ae1..000000000000
--- a/dev-libs/liblist/files/liblist-2.1-sharedlib.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- Makefile.orig 2009-11-27 12:04:33.000000000 -0800
-+++ Makefile 2009-11-27 12:11:47.786739617 -0800
-@@ -25,12 +25,22 @@
- LIBS = -L. -llist
- #LIBS = -L . -llist # Use this for HP-UX; great loader guys!
- CPP = cpp -E -P -C
-+CC = cc
-+LD = cc
- MANDIR = /usr/share/man
- LIBDIR = /usr/lib
- INCDIR = /usr/include
-
- #add macro for ranlib 4/96 *kob* - ranlib doesn't exist on solaris
- RANLIB = ls
-+LN = ln -s
-+
-+# try making shared lib (SLA 11/2009)
-+SHARED = liblist.so
-+LDFLAGS += -L$(LIBDIR)
-+MKOBJ = $(CC) -fPIC -c list.c -I$(INCDIR)
-+MKSO = -shared -Wl,-soname,$(SHARED)
-+SOVER = 0.0
-
- # We specify some goofy dependencies between the man pages and the source,
- # because the man page reflects whether USE_MACROS was specified. Thus,
-@@ -42,8 +52,16 @@
- (cd examples; make)
-
- liblist.a: list.o
-+ @echo "Making static lib ..."
- ar rc liblist.a list.o
- $(RANLIB) liblist.a
-+ @echo "done"
-+ @echo "Making shared lib $(SHARED) ..."
-+ $(MKOBJ) -I.
-+ $(LD) -I. $(MKSO) list.o -o $(SHARED).$(SOVER) $(LDFLAGS)
-+ $(LN) $(SHARED).$(SOVER) $(SHARED).0
-+ $(LN) $(SHARED).$(SOVER) $(SHARED)
-+ @echo "done"
-
- list.o: list.h list.3 Makefile
-
-@@ -62,6 +80,7 @@
- install:
- install -c liblist.a $(DESTDIR)$(LIBDIR)
- $(RANLIB) $(DESTDIR)$(LIBDIR)/liblist.a
-+ install -c liblist.so $(DESTDIR)$(LIBDIR)
- install -c list.h $(DESTDIR)$(INCDIR)
- install -c queue.h $(DESTDIR)$(INCDIR)
- install -c stack.h $(DESTDIR)$(INCDIR)
-@@ -73,5 +92,5 @@
- install -c stack.3 $(DESTDIR)$(MANDIR)/man3
-
- clean:
-- rm -f *.o *.a list.h *.3 core
-+ rm -f *.o *.a *.so list.h *.3 core
- (cd examples; make clean)
diff --git a/dev-libs/liblist/liblist-2.1-r1.ebuild b/dev-libs/liblist/liblist-2.1-r1.ebuild
deleted file mode 100644
index 9259bcc54e45..000000000000
--- a/dev-libs/liblist/liblist-2.1-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/liblist-2.1-r1.ebuild,v 1.2 2010/01/03 05:27:01 nerdboy Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks."
-HOMEPAGE="http://www.gentoogeek.org/viewvc/C/liblist/"
-SRC_URI="http://www.gentoogeek.org/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc examples"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-sharedlib.patch
- sed -i -e "s:/usr/lib:/usr/$(get_libdir):g" Makefile \
- examples/cache/Makefile || die "sed 1 failed"
-}
-
-src_compile() {
- make CC="$(tc-getCC)" LD="$(tc-getCC)" \
- || die "make failed"
-}
-
-src_install() {
- newman list.3 llist.3
- newman stack.man lstack.3
- newman queue.man lqueue.3
- dolib.a ${PN}.a
- dolib.so ${PN}.so*
- insinto /usr/include
- doins list.h queue.h stack.h
- dodoc README
-
- if use examples; then
- dolib.a examples/cache/libcache.a
- dobin examples/cache/cachetest
- newman cache.3 lcache.3
- insinto /usr/share/doc/${P}/examples
- doins examples/{*.c,Makefile,README}
- insinto /usr/share/doc/${P}/examples/cache
- doins examples/cache/{*.c,Makefile,README}
- doins
- fi
-
- if use doc; then
- insinto /usr/share/doc/${P}
- doins paper/paper.ps
- fi
-}
-
-pkg_postinst() {
- elog "Note the man pages for this package have been renamed to avoid"
- elog "name collisions with some system functions, however, the libs"
- elog "and header files have not been changed."
- elog "The new names are llist, lcache, lqueue, and lstack."
-}
diff --git a/dev-libs/liblist/liblist-2.1.ebuild b/dev-libs/liblist/liblist-2.1.ebuild
deleted file mode 100644
index 35be0f9a4ea3..000000000000
--- a/dev-libs/liblist/liblist-2.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblist/liblist-2.1.ebuild,v 1.1 2009/04/20 05:44:09 nerdboy Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks."
-HOMEPAGE="http://www.gentoogeek.org/viewvc/C/liblist/"
-SRC_URI="http://www.gentoogeek.org/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc examples"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s:/usr/lib:/usr/$(get_libdir):g" Makefile \
- examples/cache/Makefile || die "sed 1 failed"
-}
-
-src_compile() {
- make CC="$(tc-getCC)" || die "make failed"
-}
-
-src_install() {
- newman list.3 llist.3
- newman stack.man lstack.3
- newman queue.man lqueue.3
- dolib.a liblist.a
- insinto /usr/include
- doins list.h queue.h stack.h
- dodoc README
-
- if use examples; then
- dolib.a examples/cache/libcache.a
- dobin examples/cache/cachetest
- newman cache.3 lcache.3
- insinto /usr/share/doc/${P}/examples
- doins examples/{*.c,Makefile,README}
- insinto /usr/share/doc/${P}/examples/cache
- doins examples/cache/{*.c,Makefile,README}
- doins
- fi
-
- if use doc; then
- insinto /usr/share/doc/${P}
- doins paper/paper.ps
- fi
-}
-
-pkg_postinst() {
- elog "Note the man pages for this package have been renamed to avoid"
- elog "name collisions with some system functions, however, the libs"
- elog "and header files have not been changed."
- elog "The new names are llist, lcache, lqueue, and lstack."
-}