summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-03-24 12:12:38 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-03-24 12:12:38 +0000
commitd6d5a5fa651903cced989f1a6ba23ce27e8ac67e (patch)
tree39cfb0a0c58576b910fc62bd37e8264e4a2de808 /dev-libs/libinput
parentApply patch to fix build problem, bug #543566. (diff)
downloadgentoo-2-d6d5a5fa651903cced989f1a6ba23ce27e8ac67e.tar.gz
gentoo-2-d6d5a5fa651903cced989f1a6ba23ce27e8ac67e.tar.bz2
gentoo-2-d6d5a5fa651903cced989f1a6ba23ce27e8ac67e.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/ChangeLog8
-rw-r--r--dev-libs/libinput/libinput-0.13.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-libs/libinput/ChangeLog b/dev-libs/libinput/ChangeLog
index 81b507962f88..3d82f01e6442 100644
--- a/dev-libs/libinput/ChangeLog
+++ b/dev-libs/libinput/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libinput
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.15 2015/03/17 18:09:11 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.16 2015/03/24 12:12:38 chithanh Exp $
+
+*libinput-0.13.0 (24 Mar 2015)
+
+ 24 Mar 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libinput-0.13.0.ebuild:
+ Version bump.
*libinput-0.12.0 (17 Mar 2015)
diff --git a/dev-libs/libinput/libinput-0.13.0.ebuild b/dev-libs/libinput/libinput-0.13.0.ebuild
new file mode 100644
index 000000000000..2fbb8c56318f
--- /dev/null
+++ b/dev-libs/libinput/libinput-0.13.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/libinput-0.13.0.ebuild,v 1.1 2015/03/24 12:12:38 chithanh Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+# License appears to be a variant of libtiff
+LICENSE="libtiff"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ --disable-tests
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc -r doc/html
+ prune_libtool_files
+}