summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-04 16:13:02 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-04 16:13:02 +0000
commitabc85858397c46e9cb40cf70e851db6cb2121164 (patch)
tree4ef61172b93edd89ada32fa5e57b354edfbe47a1 /dev-libs/libinput
parentenum34-1.0.4: keyword ~x86-linux (diff)
downloadgentoo-2-abc85858397c46e9cb40cf70e851db6cb2121164.tar.gz
gentoo-2-abc85858397c46e9cb40cf70e851db6cb2121164.tar.bz2
gentoo-2-abc85858397c46e9cb40cf70e851db6cb2121164.zip
Version bump, bug #536868. Add x11 to maintainers.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/ChangeLog11
-rw-r--r--dev-libs/libinput/libinput-0.8.0.ebuild50
-rw-r--r--dev-libs/libinput/metadata.xml1
3 files changed, 59 insertions, 3 deletions
diff --git a/dev-libs/libinput/ChangeLog b/dev-libs/libinput/ChangeLog
index dbe775c26bad..4f49d1715963 100644
--- a/dev-libs/libinput/ChangeLog
+++ b/dev-libs/libinput/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libinput
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.2 2014/12/30 19:52:16 maekke Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.3 2015/02/04 16:13:02 chithanh Exp $
+
+*libinput-0.8.0 (04 Feb 2015)
+
+ 04 Feb 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libinput-0.8.0.ebuild, metadata.xml:
+ Version bump, bug #536868. Add x11 to maintainers.
30 Dec 2014; Markus Meier <maekke@gentoo.org> libinput-0.7.0.ebuild:
add ~arm, bug #533420
@@ -11,4 +17,3 @@
+metadata.xml:
Initial ebuild. Needed for wayland support in media-libs/clutter. Closes bug
#513856.
-
diff --git a/dev-libs/libinput/libinput-0.8.0.ebuild b/dev-libs/libinput/libinput-0.8.0.ebuild
new file mode 100644
index 000000000000..4e0c6a15df34
--- /dev/null
+++ b/dev-libs/libinput/libinput-0.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/libinput-0.8.0.ebuild,v 1.1 2015/02/04 16:13:02 chithanh Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+# License appears to be a variant of libtiff
+LICENSE="libtiff"
+SLOT="0/7"
+KEYWORDS="~amd64 ~arm"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-libs/check-0.9.10 )
+"
+# tests can even use: dev-util/valgrind
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc -r doc/html
+ prune_libtool_files
+}
diff --git a/dev-libs/libinput/metadata.xml b/dev-libs/libinput/metadata.xml
index da6fd63d0085..42473bf06aa3 100644
--- a/dev-libs/libinput/metadata.xml
+++ b/dev-libs/libinput/metadata.xml
@@ -2,4 +2,5 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome</herd>
+<herd>x11</herd>
</pkgmetadata>