summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-11-01 16:37:24 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-11-01 16:37:24 +0000
commit8e770ded38a41d6dd1e5b6cbf135eb80f2bcaf15 (patch)
tree9c60ba0b80463430c3e85eb9f5c946030ad2f6ee /dev-libs/libidmef
parentadd mirror://gentoo as SRC_URI fallback since upstream removes old version wh... (diff)
downloadgentoo-2-8e770ded38a41d6dd1e5b6cbf135eb80f2bcaf15.tar.gz
gentoo-2-8e770ded38a41d6dd1e5b6cbf135eb80f2bcaf15.tar.bz2
gentoo-2-8e770ded38a41d6dd1e5b6cbf135eb80f2bcaf15.zip
Version bump: EAPI 4, add ~amd64 keyword wrt bug #440766, add USE flags 'debug' and 'static-libs'
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libidmef')
-rw-r--r--dev-libs/libidmef/ChangeLog10
-rw-r--r--dev-libs/libidmef/libidmef-1.0.3.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-libs/libidmef/ChangeLog b/dev-libs/libidmef/ChangeLog
index 2f0b0ab0d322..81de20257563 100644
--- a/dev-libs/libidmef/ChangeLog
+++ b/dev-libs/libidmef/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libidmef
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libidmef/ChangeLog,v 1.7 2009/12/23 16:53:51 vostorga Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libidmef/ChangeLog,v 1.8 2012/11/01 16:37:24 pinkbyte Exp $
+
+*libidmef-1.0.3 (01 Nov 2012)
+
+ 01 Nov 2012; Sergey Popov <pinkbyte@gentoo.org> +libidmef-1.0.3.ebuild:
+ Version bump: EAPI 4, add ~amd64 keyword wrt bug #440766, add USE flags
+ 'debug' and 'static-libs'
23 Dec 2009; Víctor Ostorga <vostorga@gentoo.org> -libidmef-0.7.2.ebuild,
libidmef-1.0.2_beta1.ebuild:
diff --git a/dev-libs/libidmef/libidmef-1.0.3.ebuild b/dev-libs/libidmef/libidmef-1.0.3.ebuild
new file mode 100644
index 000000000000..e08506847bf1
--- /dev/null
+++ b/dev-libs/libidmef/libidmef-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libidmef/libidmef-1.0.3.ebuild,v 1.1 2012/11/01 16:37:24 pinkbyte Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Implementation of the IDMEF XML draft"
+HOMEPAGE="http://sourceforge.net/projects/libidmef/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND=">=dev-libs/libxml2-2.5.10"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README TODO )
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}