summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-17 00:10:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-17 00:10:38 +0000
commitf87c7299e197aed07d0340554a72cb277ce49dcd (patch)
treec96a2511470fd9642fcf6e3db867575d28dc4b76 /dev-libs/libhid
parentold (diff)
downloadgentoo-2-f87c7299e197aed07d0340554a72cb277ce49dcd.tar.gz
gentoo-2-f87c7299e197aed07d0340554a72cb277ce49dcd.tar.bz2
gentoo-2-f87c7299e197aed07d0340554a72cb277ce49dcd.zip
Respect LDFLAGS. Remove useless .la file. Fixes bug #313841
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libhid')
-rw-r--r--dev-libs/libhid/ChangeLog8
-rw-r--r--dev-libs/libhid/libhid-0.2.16-r3.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-libs/libhid/ChangeLog b/dev-libs/libhid/ChangeLog
index 7c0bdfa53527..fa71c43a164d 100644
--- a/dev-libs/libhid/ChangeLog
+++ b/dev-libs/libhid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libhid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/ChangeLog,v 1.3 2010/04/04 14:56:17 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/ChangeLog,v 1.4 2010/07/17 00:10:38 hwoarang Exp $
+
+*libhid-0.2.16-r3 (17 Jul 2010)
+
+ 17 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ +libhid-0.2.16-r3.ebuild:
+ Respect LDFLAGS. Remove useless .la file. Fixes bug #313841
*libhid-0.2.16-r2 (04 Apr 2010)
diff --git a/dev-libs/libhid/libhid-0.2.16-r3.ebuild b/dev-libs/libhid/libhid-0.2.16-r3.ebuild
new file mode 100644
index 000000000000..86384b0a5d0e
--- /dev/null
+++ b/dev-libs/libhid/libhid-0.2.16-r3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/libhid-0.2.16-r3.ebuild,v 1.1 2010/07/17 00:10:38 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="python? 2"
+
+inherit autotools python
+
+DESCRIPTION="Provides a generic and flexible way to access and interact with USB HID devices"
+HOMEPAGE="http://libhid.alioth.debian.org/"
+SRC_URI="http://beta.magicaltux.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc python"
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ export OS_LDFLAGS="${LDFLAGS}"
+ # Bug #260884
+ sed -i -e 's/-Werror//' m4/md_conf_compiler.m4 || die
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+
+ myconf="${myconf} $(use_with doc doxygen)"
+ myconf="${myconf} $(use_enable debug)"
+ myconf="${myconf} $(use_enable python swig)"
+
+ if use python; then
+ # libhid includes its own python detection m4 from
+ # http://autoconf-archive.cryp.to/ac_python_devel.html
+ # As it seems to detect python in the wrong place, we'll force it by
+ # passing the right environnement variables, only if we have the python
+ # flag
+ PYTHON_LDFLAGS="$(python-config --ldflags)" econf ${myconf} || die
+ else
+ # avoid libhid running swig if it finds it automatically as long as the
+ # "python" use flag is not set
+ econf ${myconf} || die
+ fi
+}
+
+src_compile() {
+ append-ldflags
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README README.licence TODO || die
+ if use doc; then
+ dohtml -r doc/html/* || die
+ fi
+ #delete .la file. Bug #313841
+ rm "${D}"/$(python_get_sitedir)/${PN}/_hid.la
+
+}