summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-02-18 20:55:36 +0000
committerUlrich Müller <ulm@gentoo.org>2012-02-18 20:55:36 +0000
commit998671f6cdeb7fc17bc0520d96975c065351cfc1 (patch)
tree12220199d67428088c05f8fff24528f975b1d283 /dev-libs/libgcrypt
parentVersion bumped to latest release, dropped 4.9.0 ebuild (more to come) (diff)
downloadgentoo-2-998671f6cdeb7fc17bc0520d96975c065351cfc1.tar.gz
gentoo-2-998671f6cdeb7fc17bc0520d96975c065351cfc1.tar.bz2
gentoo-2-998671f6cdeb7fc17bc0520d96975c065351cfc1.zip
Re-add support for the IDEA cipher, bug 159870.
(Portage version: 2.1.10.47/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/ChangeLog9
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.5.0-r2.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index 8f4fb6565338..00c3c76983ea 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgcrypt
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.152 2011/09/22 14:44:39 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.153 2012/02/18 20:55:36 ulm Exp $
+
+*libgcrypt-1.5.0-r2 (18 Feb 2012)
+
+ 18 Feb 2012; Ulrich Müller <ulm@gentoo.org> +libgcrypt-1.5.0-r2.ebuild:
+ Re-add support for the IDEA cipher, bug 159870.
*libgcrypt-1.5.0-r1 (22 Sep 2011)
diff --git a/dev-libs/libgcrypt/libgcrypt-1.5.0-r2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..3648f8bbd674
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.5.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.5.0-r2.ebuild,v 1.1 2012/02/18 20:55:36 ulm Exp $
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
+ ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}-idea.patch.bz2"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgpg-error-1.8"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-uscore.patch
+ epatch "${FILESDIR}"/${PN}-multilib-syspath.patch
+ epatch "${WORKDIR}"/${P}-idea.patch
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-padlock-support for bug #201917
+ econf \
+ --disable-padlock-support \
+ --disable-dependency-tracking \
+ --enable-noexecstack \
+ --disable-O-flag-munging \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}