summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-13 02:23:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-13 02:23:33 +0000
commit38de2c28694f68da56424faea7aaa2b57605e65a (patch)
tree01a3e0638fb70e2ae7c8a9335197bc3e8f798e88 /dev-libs/libgcrypt
parentversion bump (diff)
downloadgentoo-2-38de2c28694f68da56424faea7aaa2b57605e65a.tar.gz
gentoo-2-38de2c28694f68da56424faea7aaa2b57605e65a.tar.bz2
gentoo-2-38de2c28694f68da56424faea7aaa2b57605e65a.zip
version bump
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/ChangeLog12
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.1.8.ebuild31
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index 2b7d51f3c24e..139fc911a2dc 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-libs/atlas
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.2 2002/08/13 19:33:12 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.3 2002/10/13 02:23:33 seemant Exp $
+
+*libgcrypt-1.1.8 (12 Oct 2002)
+
+ 12 Oct 2002; Seemant Kulleen <seemant@gentoo.org> libgcrypt-1.1.8.ebuild
+ files/digest-libgcrypt-1.1.8 :
+
+ Version bump. License is now LGPL-2.1 unless using a unix without
+ /dev/random or windows, in which case use GPL-2. Removed myconf settings
+ from 1.1.3 since README mentioned nothing about them. Added docs in
+ src_install.
*libgcrypt-1.1.3 (15 Mar 2002 )
diff --git a/dev-libs/libgcrypt/libgcrypt-1.1.8.ebuild b/dev-libs/libgcrypt/libgcrypt-1.1.8.ebuild
new file mode 100644
index 000000000000..55135646c2ae
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.1.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.1.8.ebuild,v 1.1 2002/10/13 02:23:33 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libgcrypt is a general purpose crypto library based on the code used in GnuPG."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/${P}.tar.gz"
+HOMEPAGE="http://www.gnupg.org"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="app-text/jadetex
+ app-text/docbook2X"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog COPYING* NEWS README* THANKS TODO VERSION
+}