summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-08 11:47:14 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-08 11:47:14 +0000
commit1138f1b0386cb701711f56ad5e51aacd802df659 (patch)
tree48d35a888439067d6cf42d76e6e8049c7595179b /dev-libs/libgamin
parentVersion bump (diff)
downloadgentoo-2-1138f1b0386cb701711f56ad5e51aacd802df659.tar.gz
gentoo-2-1138f1b0386cb701711f56ad5e51aacd802df659.tar.bz2
gentoo-2-1138f1b0386cb701711f56ad5e51aacd802df659.zip
Fix deadlock, bug #420353 by Michael Boone.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgamin')
-rw-r--r--dev-libs/libgamin/ChangeLog9
-rw-r--r--dev-libs/libgamin/files/libgamin-0.1.10-deadlock.patch65
-rw-r--r--dev-libs/libgamin/libgamin-0.1.10-r3.ebuild144
3 files changed, 216 insertions, 2 deletions
diff --git a/dev-libs/libgamin/ChangeLog b/dev-libs/libgamin/ChangeLog
index d1fb308a1037..ea86afd037b3 100644
--- a/dev-libs/libgamin/ChangeLog
+++ b/dev-libs/libgamin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libgamin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.31 2012/04/30 14:29:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.32 2012/07/08 11:47:14 pacho Exp $
+
+*libgamin-0.1.10-r3 (08 Jul 2012)
+
+ 08 Jul 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/libgamin-0.1.10-deadlock.patch, +libgamin-0.1.10-r3.ebuild:
+ Fix deadlock, bug #420353 by Michael Boone.
30 Apr 2012; Fabian Groffen <grobian@gentoo.org> libgamin-0.1.10-r2.ebuild:
Fix for Prefix, add (Open)Solaris patch, bug #413415
@@ -125,4 +131,3 @@
+libgamin-0.1.10.ebuild, +metadata.xml:
New ebuild split off gamin. Initial ebuild inspired by Pacho Ramos, closes
bug #217861.
-
diff --git a/dev-libs/libgamin/files/libgamin-0.1.10-deadlock.patch b/dev-libs/libgamin/files/libgamin-0.1.10-deadlock.patch
new file mode 100644
index 000000000000..9f2b2a5150bd
--- /dev/null
+++ b/dev-libs/libgamin/files/libgamin-0.1.10-deadlock.patch
@@ -0,0 +1,65 @@
+From cc14440eface093548cb3bc7814da11d9a99d283 Mon Sep 17 00:00:00 2001
+From: Anssi Hannula <anssi@mageia.org>
+Date: Wed, 4 Jan 2012 00:23:55 +0200
+Subject: [PATCH] fix possible server deadlock in ih_sub_cancel
+
+ih_sub_foreach() calls ih_sub_cancel() while inotify_lock is locked.
+However, ih_sub_cancel() locks it again, and locking GMutex recursively
+causes undefined behaviour.
+
+Fix that by removing locking from ih_sub_cancel() as ih_sub_foreach()
+is its only user. Also make the function static so that it won't
+accidentally get used by other files without locking (inotify-helper.h
+is an internal server header).
+
+This should fix the intermittent deadlocks I've been experiencing
+causing KDE applications to no longer start, and probably also
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=542361
+---
+ server/inotify-helper.c | 7 ++-----
+ server/inotify-helper.h | 1 -
+ 2 files changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/server/inotify-helper.c b/server/inotify-helper.c
+index d77203e..0789fa4 100644
+--- a/server/inotify-helper.c
++++ b/server/inotify-helper.c
+@@ -123,13 +123,11 @@ ih_sub_add (ih_sub_t * sub)
+
+ /**
+ * Cancels a subscription which was being monitored.
++ * inotify_lock must be held when calling.
+ */
+-gboolean
++static gboolean
+ ih_sub_cancel (ih_sub_t * sub)
+ {
+- G_LOCK(inotify_lock);
+-
+-
+ if (!sub->cancelled)
+ {
+ IH_W("cancelling %s\n", sub->pathname);
+@@ -140,7 +138,6 @@ ih_sub_cancel (ih_sub_t * sub)
+ sub_list = g_list_remove (sub_list, sub);
+ }
+
+- G_UNLOCK(inotify_lock);
+ return TRUE;
+ }
+
+diff --git a/server/inotify-helper.h b/server/inotify-helper.h
+index 5d3b6d0..d36b5fd 100644
+--- a/server/inotify-helper.h
++++ b/server/inotify-helper.h
+@@ -34,7 +34,6 @@ gboolean ih_startup (event_callback_t ecb,
+ found_callback_t fcb);
+ gboolean ih_running (void);
+ gboolean ih_sub_add (ih_sub_t *sub);
+-gboolean ih_sub_cancel (ih_sub_t *sub);
+
+ /* Return FALSE from 'f' if the subscription should be cancelled */
+ void ih_sub_foreach (void *callerdata, gboolean (*f)(ih_sub_t *sub, void *callerdata));
+--
+1.7.7.2
+
diff --git a/dev-libs/libgamin/libgamin-0.1.10-r3.ebuild b/dev-libs/libgamin/libgamin-0.1.10-r3.ebuild
new file mode 100644
index 000000000000..404fe9d0b670
--- /dev/null
+++ b/dev-libs/libgamin/libgamin-0.1.10-r3.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r3.ebuild,v 1.1 2012/07/08 11:47:14 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+GNOME_ORG_MODULE="gamin"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils flag-o-matic libtool python gnome.org
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gamin-0.1.9-freebsd.patch.bz2
+ http://dev.gentoo.org/~grobian/patches/libgamin-0.1.10-opensolaris.patch.bz2
+ http://pkgconfig.freedesktop.org/releases/pkg-config-0.26.tar.gz" # pkg.m4 for eautoreconf
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug kernel_linux python static-libs"
+
+RESTRICT="test" # needs gam-server
+
+RDEPEND="!app-admin/fam
+ !<app-admin/gamin-0.1.10"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ mv -vf "${WORKDIR}"/pkg-config-*/pkg.m4 "${WORKDIR}"/ || die
+
+ # Fix QA warnings, bug #257281, upstream #466791
+ epatch "${FILESDIR}"/${PN}-0.1.10-compilewarnings.patch
+
+ if [[ ${CHOST} != *-solaris* ]] ; then
+ # Fix compile warnings; bug #188923
+ epatch "${DISTDIR}"/gamin-0.1.9-freebsd.patch.bz2
+ else
+ # (Open)Solaris necessary patches (changes configure.in), unfortunately
+ # conflicts with freebsd patch and breaks some linux installs so it must
+ # only be applied if on solaris.
+ epatch "${DISTDIR}"/${P}-opensolaris.patch.bz2
+ fi
+
+ # Fix collision problem due to intermediate library, upstream bug #530635
+ epatch "${FILESDIR}"/${PN}-0.1.10-noinst-lib.patch
+
+ # Fix compilation with latest glib, bug #382783
+ epatch "${FILESDIR}/${PN}-0.1.10-G_CONST_RETURN-removal.patch"
+
+ # Fix crosscompilation issues, bug #267604
+ epatch "${FILESDIR}/${PN}-0.1.10-crosscompile-fix.patch"
+
+ # Enable linux specific features on armel, upstream bug #588338
+ epatch "${FILESDIR}/${P}-armel-features.patch"
+
+ # Fix possible server deadlock in ih_sub_cancel, upstream bug #667230
+ epatch "${FILESDIR}/${PN}-0.1.10-deadlock.patch"
+
+ # Drop DEPRECATED flags
+ sed -i -e 's:-DG_DISABLE_DEPRECATED:$(NULL):g' server/Makefile.am || die
+
+ # Build only shared version of Python module.
+ epatch "${FILESDIR}"/${PN}-0.1.10-disable_python_static_library.patch
+
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS += python/d" -i Makefile.am
+
+ # autoconf is required as the user-cflags patch modifies configure.in
+ # however, elibtoolize is also required, so when the above patch is
+ # removed, replace the following call with a call to elibtoolize
+ AT_M4DIR="${WORKDIR}" eautoreconf
+
+ use python && python_clean_py-compile_files
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-debug \
+ --disable-server \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug debug-api) \
+ $(use_with python)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake \
+ PYTHON_INCLUDES="${EPREFIX}$(python_get_includedir)" \
+ PYTHON_SITE_PACKAGES="${EPREFIX}$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_SITE_PACKAGES="${EPREFIX}$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_installation_image
+ fi
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+ dohtml doc/*
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize gamin.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup gamin.py
+ fi
+}