summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-29 17:40:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-29 17:40:29 +0000
commit7b285099f989b2a495621f239d6036a048848ec7 (patch)
tree47591c9d6bcec53002901e4aeb181a9183f1b6c3 /dev-libs/libffi/libffi-3.0.10.ebuild
parentChange version scheme (diff)
downloadgentoo-2-7b285099f989b2a495621f239d6036a048848ec7.tar.gz
gentoo-2-7b285099f989b2a495621f239d6036a048848ec7.tar.bz2
gentoo-2-7b285099f989b2a495621f239d6036a048848ec7.zip
Version bump to 3.0.10 final (interix patch not necessary). Somehow this lowers, rather than increase, the soversion.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libffi/libffi-3.0.10.ebuild')
-rw-r--r--dev-libs/libffi/libffi-3.0.10.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libffi/libffi-3.0.10.ebuild b/dev-libs/libffi/libffi-3.0.10.ebuild
new file mode 100644
index 000000000000..fef6b9dc4766
--- /dev/null
+++ b/dev-libs/libffi/libffi-3.0.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.10.ebuild,v 1.1 2011/08/29 17:40:29 flameeyes Exp $
+
+EAPI=2
+
+MY_P=${P/_}
+
+inherit libtool toolchain-funcs eutils
+
+DESCRIPTION="a portable, high level programming interface to various calling conventions."
+HOMEPAGE="http://sourceware.org/libffi/"
+SRC_URI="ftp://sourceware.org/pub/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-util/dejagnu )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # Detect and document broken installation of sys-devel/gcc in the build.log wrt #354903
+ if ! has_version dev-libs/libffi; then
+ local base="${T}/conftest"
+ echo 'int main() { }' > "${base}.c"
+ $(tc-getCC) -o "${base}" "${base}.c" -lffi >&/dev/null && \
+ ewarn "Found a copy of second libffi in your system. Uninstall it before continuing."
+ fi
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ use userland_BSD && export HOST="${CHOST}"
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog* README
+ find "${D}" -name '*.la' -exec rm -f {} +
+}