summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-11-19 20:12:26 +0000
committerJason Wever <weeve@gentoo.org>2003-11-19 20:12:26 +0000
commit8dc9446426fdc608c1281fa6b9766a7b9a2c1e1b (patch)
tree96359aa7ce11c4627eb4d4ae351b5aa2b71de9ae /dev-libs/libezV24/libezV24-0.1.1.ebuild
parentinitial import. (diff)
downloadgentoo-2-8dc9446426fdc608c1281fa6b9766a7b9a2c1e1b.tar.gz
gentoo-2-8dc9446426fdc608c1281fa6b9766a7b9a2c1e1b.tar.bz2
gentoo-2-8dc9446426fdc608c1281fa6b9766a7b9a2c1e1b.zip
initial import.
Diffstat (limited to 'dev-libs/libezV24/libezV24-0.1.1.ebuild')
-rw-r--r--dev-libs/libezV24/libezV24-0.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libezV24/libezV24-0.1.1.ebuild b/dev-libs/libezV24/libezV24-0.1.1.ebuild
new file mode 100644
index 000000000000..6901f105118a
--- /dev/null
+++ b/dev-libs/libezV24/libezV24-0.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libezV24/libezV24-0.1.1.ebuild,v 1.1 2003/11/19 20:12:23 weeve Exp $
+
+IUSE=""
+S=${WORKDIR}/${P}
+DESCRIPTION="libezV24 - library that provides an easy API to Linux serial ports"
+HOMEPAGE="http://ezv24.sf.net"
+SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
+DEPEND=""
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc ~sparc ~alpha"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-test-v24.c.diff
+ epatch ${FILESDIR}/${P}-Makefile.diff
+ emake || die "Make failed"
+}
+
+src_install() {
+ make install PREFIX=${D}usr || die "Make install failed"
+ dodoc AUTHORS BUGS COPYING ChangeLog HISTORY README
+ dohtml api-html/*
+
+ # make install makes symlinks that don't exist when installed, so
+ # replace them and re-create with dosym
+
+ rm ${D}/usr/lib/libezV24.so
+ rm ${D}/usr/lib/libezV24.so.0
+
+ dosym libezV24.so.0.1 /usr/lib/libezV24.so.0
+ dosym libezV24.so.0 /usr/lib/libezV24.so
+}