summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-10 19:32:13 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-10 19:32:13 +0000
commit0a10a5f8a4819d53bfd7144588056f61a7246a4a (patch)
tree34805b8ef808f1c29918e7d9ad473089ce352c7b /dev-libs/libexplain
parentppc stable wrt #389181 (diff)
downloadgentoo-2-0a10a5f8a4819d53bfd7144588056f61a7246a4a.tar.gz
gentoo-2-0a10a5f8a4819d53bfd7144588056f61a7246a4a.tar.bz2
gentoo-2-0a10a5f8a4819d53bfd7144588056f61a7246a4a.zip
Version bump.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libexplain')
-rw-r--r--dev-libs/libexplain/ChangeLog7
-rw-r--r--dev-libs/libexplain/libexplain-0.49.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/libexplain/ChangeLog b/dev-libs/libexplain/ChangeLog
index 7c37f3a311c3..b6d731e7e588 100644
--- a/dev-libs/libexplain/ChangeLog
+++ b/dev-libs/libexplain/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libexplain
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.8 2011/09/28 23:14:26 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.9 2011/11/10 19:32:13 radhermit Exp $
+
+*libexplain-0.49 (10 Nov 2011)
+
+ 10 Nov 2011; Tim Harder <radhermit@gentoo.org> +libexplain-0.49.ebuild:
+ Version bump.
*libexplain-0.47 (28 Sep 2011)
diff --git a/dev-libs/libexplain/libexplain-0.49.ebuild b/dev-libs/libexplain/libexplain-0.49.ebuild
new file mode 100644
index 000000000000..a76b8865aaf2
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-0.49.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-0.49.ebuild,v 1.1 2011/11/10 19:32:13 radhermit Exp $
+
+EAPI=4
+inherit autotools-utils eutils
+
+MY_P="${P}.D001"
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="static-libs"
+
+DEPEND="
+ >=sys-kernel/linux-headers-2.6.35
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( README )
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ epatch "${FILESDIR}"/${PN}-0.45-configure.patch
+
+ cp "${S}"/etc/configure.ac "${S}"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}