summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-20 15:46:40 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-20 15:46:40 +0000
commit4dddf424da37a6af6c6873ac3761c85fb463258c (patch)
tree477dcd3c8b6d3f12d66692b5748af2f28f654784 /dev-libs/libdnet
parentRemoved old (vulnerable?) versions. Converted libotr-4.0.0.ebuild to EAPI-5 (diff)
downloadgentoo-2-4dddf424da37a6af6c6873ac3761c85fb463258c.tar.gz
gentoo-2-4dddf424da37a6af6c6873ac3761c85fb463258c.tar.bz2
gentoo-2-4dddf424da37a6af6c6873ac3761c85fb463258c.zip
Fix building with python3 (bug #473924 by Willard Dawson).
(Portage version: 2.2.0_alpha182/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/ChangeLog5
-rw-r--r--dev-libs/libdnet/libdnet-1.12.ebuild25
2 files changed, 26 insertions, 4 deletions
diff --git a/dev-libs/libdnet/ChangeLog b/dev-libs/libdnet/ChangeLog
index e0681fc1d34d..51edce883741 100644
--- a/dev-libs/libdnet/ChangeLog
+++ b/dev-libs/libdnet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libdnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.63 2013/06/19 08:02:31 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.64 2013/06/20 15:46:40 jer Exp $
+
+ 20 Jun 2013; Jeroen Roovers <jer@gentoo.org> libdnet-1.12.ebuild:
+ Fix building with python3 (bug #473924 by Willard Dawson).
19 Jun 2013; Chema Alonso <nimiux@gentoo.org> libdnet-1.12.ebuild:
Stable for amd64 wrt bug #471420
diff --git a/dev-libs/libdnet/libdnet-1.12.ebuild b/dev-libs/libdnet/libdnet-1.12.ebuild
index 100b0ad1247d..d3b36480ff54 100644
--- a/dev-libs/libdnet/libdnet-1.12.ebuild
+++ b/dev-libs/libdnet/libdnet-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.12.ebuild,v 1.7 2013/06/19 08:02:31 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.12.ebuild,v 1.8 2013/06/20 15:46:40 jer Exp $
EAPI=5
@@ -9,8 +9,9 @@ AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
PYTHON_DEPEND="python? 2"
PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+DISTUTILS_SINGLE_IMPL=true
-inherit autotools-utils eutils python-r1
+inherit autotools distutils-r1 eutils
DESCRIPTION="simplified, portable interface to several low-level networking routines"
HOMEPAGE="http://code.google.com/p/libdnet/"
@@ -37,7 +38,8 @@ src_prepare() {
configure.in || die
sed -i -e 's|-L@libdir@ ||g' dnet-config.in || die
use ipv6 && epatch "${WORKDIR}/${P}.ipv6-1.patch"
- autotools-utils_src_prepare
+ eautoreconf
+ use python && distutils-r1_src_prepare
}
src_configure() {
@@ -45,3 +47,20 @@ src_configure() {
$(use_with python) \
$(use_enable static-libs static)
}
+
+src_compile() {
+ default
+ if use python; then
+ cd python
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ default
+ if use python; then
+ cd python
+ distutils-r1_src_compile
+ fi
+ prune_libtool_files
+}