summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-10 06:50:37 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-10 06:50:37 +0000
commit0ae917b5f88b52a819933494c99411ed23a81056 (patch)
tree8080526d800861acd389e3fddddd0399e0794423 /dev-libs/libdnet
parentx86 stable, see bug 423673. Thanks Myckel Habets for testing. (diff)
downloadgentoo-2-0ae917b5f88b52a819933494c99411ed23a81056.tar.gz
gentoo-2-0ae917b5f88b52a819933494c99411ed23a81056.tar.bz2
gentoo-2-0ae917b5f88b52a819933494c99411ed23a81056.zip
Version bump with optional ipv6 support, add upstream info to metadata
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/ChangeLog8
-rw-r--r--dev-libs/libdnet/libdnet-1.12.ebuild48
-rw-r--r--dev-libs/libdnet/metadata.xml5
3 files changed, 59 insertions, 2 deletions
diff --git a/dev-libs/libdnet/ChangeLog b/dev-libs/libdnet/ChangeLog
index b45d943edc2b..296637721bf6 100644
--- a/dev-libs/libdnet/ChangeLog
+++ b/dev-libs/libdnet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdnet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.56 2012/07/08 17:29:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.57 2012/10/10 06:50:37 pinkbyte Exp $
+
+*libdnet-1.12 (10 Oct 2012)
+
+ 10 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +libdnet-1.12.ebuild,
+ metadata.xml:
+ Version bump with optional ipv6 support, add upstream info to metadata
08 Jul 2012; Raúl Porcel <armin76@gentoo.org> libdnet-1.11-r2.ebuild:
alpha/ia64/sparc stable wrt #418751
diff --git a/dev-libs/libdnet/libdnet-1.12.ebuild b/dev-libs/libdnet/libdnet-1.12.ebuild
new file mode 100644
index 000000000000..dab439c9f516
--- /dev/null
+++ b/dev-libs/libdnet/libdnet-1.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.12.ebuild,v 1.1 2012/10/10 06:50:37 pinkbyte Exp $
+
+EAPI=4
+
+AT_M4DIR="config"
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+PYTHON_DEPEND="python? 2"
+
+inherit autotools-utils eutils python
+
+DESCRIPTION="simplified, portable interface to several low-level networking routines"
+HOMEPAGE="http://code.google.com/p/libdnet/"
+SRC_URI="http://libdnet.googlecode.com/files/${P}.tgz
+ ipv6? ( http://fragroute-ipv6.googlecode.com/files/${P}.ipv6-1.patch.gz )"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 python static-libs test"
+
+DEPEND="test? ( dev-libs/check )"
+RDEPEND=""
+
+RESTRICT="test"
+
+DOCS=( README THANKS TODO )
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e 's/libcheck.a/libcheck.so/g' configure.in || die "sed failed"
+ use ipv6 && epatch "${WORKDIR}/${P}.ipv6-1.patch"
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ econf \
+ $(use_with python) \
+ $(use_enable static-libs static)
+}
diff --git a/dev-libs/libdnet/metadata.xml b/dev-libs/libdnet/metadata.xml
index 03aa50bab7e3..fb093adfd4cc 100644
--- a/dev-libs/libdnet/metadata.xml
+++ b/dev-libs/libdnet/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>netmon</herd>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="google-code">libdnet</remote-id>
+ </upstream>
</pkgmetadata>