summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-12-21 10:24:32 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-12-21 10:24:32 +0000
commitbcdd3897669759e4dc6ab69fb00d6dfd6b771552 (patch)
treed9e7719691b0ac607320cdfe44c9adce1405bf2a /dev-libs/libdaemon/libdaemon-0.7.ebuild
parentMade tcl multilib friendly. (Manifest recommit) (diff)
downloadgentoo-2-bcdd3897669759e4dc6ab69fb00d6dfd6b771552.tar.gz
gentoo-2-bcdd3897669759e4dc6ab69fb00d6dfd6b771552.tar.bz2
gentoo-2-bcdd3897669759e4dc6ab69fb00d6dfd6b771552.zip
Remove --enable/disable-doxygen since upstream doesnt provide it anymore - bug 75068.
Diffstat (limited to 'dev-libs/libdaemon/libdaemon-0.7.ebuild')
-rw-r--r--dev-libs/libdaemon/libdaemon-0.7.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-libs/libdaemon/libdaemon-0.7.ebuild b/dev-libs/libdaemon/libdaemon-0.7.ebuild
index e058fe112a90..4ffba728c8d9 100644
--- a/dev-libs/libdaemon/libdaemon-0.7.ebuild
+++ b/dev-libs/libdaemon/libdaemon-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.7.ebuild,v 1.2 2004/12/20 22:29:09 config Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.7.ebuild,v 1.3 2004/12/21 10:24:32 ka0ttic Exp $
DESCRIPTION="Simple library for creating daemon processes in C"
HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
@@ -14,12 +14,9 @@ IUSE="doc"
DEPEND="doc? ( app-doc/doxygen net-www/lynx )"
src_compile() {
- local myconf="--disable-doxygen --disable-lynx"
- use doc && myconf="--enable-doxygen --enable-lynx"
-
- econf ${myconf} || die "econf failed"
-
+ econf $(use_enable doc lynx) || die "econf failed"
emake || die "emake failed"
+
if use doc ; then
einfo "Building documentation"
make doxygen || die "make doxygen failed"