summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 23:16:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 23:16:43 +0000
commit02a9e16e24febac83aca086e75d8dd496a8b93dc (patch)
treefde08c363085a40a9978df2c8a349c4e7f801873 /dev-libs/libbulletml
parentFix building with gcc-4.3 (diff)
downloadgentoo-2-02a9e16e24febac83aca086e75d8dd496a8b93dc.tar.gz
gentoo-2-02a9e16e24febac83aca086e75d8dd496a8b93dc.tar.bz2
gentoo-2-02a9e16e24febac83aca086e75d8dd496a8b93dc.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-libs/libbulletml')
-rw-r--r--dev-libs/libbulletml/ChangeLog8
-rw-r--r--dev-libs/libbulletml/files/libbulletml-0.0.6-gcc43.patch31
-rw-r--r--dev-libs/libbulletml/libbulletml-0.0.6.ebuild20
3 files changed, 51 insertions, 8 deletions
diff --git a/dev-libs/libbulletml/ChangeLog b/dev-libs/libbulletml/ChangeLog
index 90f77c7deead..001353b854bc 100644
--- a/dev-libs/libbulletml/ChangeLog
+++ b/dev-libs/libbulletml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libbulletml
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/ChangeLog,v 1.6 2007/02/09 07:29:49 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/ChangeLog,v 1.7 2008/04/30 23:16:43 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/libbulletml-0.0.6-gcc43.patch, libbulletml-0.0.6.ebuild:
+ Fix building with gcc-4.3
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-libs/libbulletml/files/libbulletml-0.0.6-gcc43.patch b/dev-libs/libbulletml/files/libbulletml-0.0.6-gcc43.patch
new file mode 100644
index 000000000000..f7e9bfbab9b1
--- /dev/null
+++ b/dev-libs/libbulletml/files/libbulletml-0.0.6-gcc43.patch
@@ -0,0 +1,31 @@
+--- src/calc.yy
++++ src/calc.yy
+@@ -8,6 +8,7 @@
+
+ #include <cmath>
+ #include <cctype>
++#include <cstring>
+
+ #include <vector>
+ #include <sstream>
+--- src/tinyxml/tinyxml.h
++++ src/tinyxml/tinyxml.h
+@@ -28,6 +28,8 @@
+ #include <string>
+ #include <stdio.h>
+ #include <assert.h>
++#include <cstring>
++#include <cstdlib>
+
+ class TiXmlDocument;
+ class TiXmlElement;
+--- src/tinyxml/tinyxmlparser.cpp
++++ src/tinyxml/tinyxmlparser.cpp
+@@ -24,6 +24,7 @@
+
+ #include "tinyxml.h"
+ #include <ctype.h>
++#include <cstring>
+
+ const char* TiXmlBase::SkipWhiteSpace( const char* p )
+ {
diff --git a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
index 1493acd27704..d6f003cc8d33 100644
--- a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
+++ b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/libbulletml-0.0.6.ebuild,v 1.5 2005/08/11 12:01:55 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/libbulletml-0.0.6.ebuild,v 1.6 2008/04/30 23:16:43 nyhm Exp $
+
+inherit eutils
DESCRIPTION="A Library of Bullet Markup Language"
HOMEPAGE="http://user.ecc.u-tokyo.ac.jp/~s31552/wp/libbulletml/index_en.html"
@@ -13,21 +15,27 @@ IUSE=""
S="${WORKDIR}/${PN#lib}/src"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "emake failed"
}
src_install() {
- dolib.a libbulletml.a
+ dolib.a libbulletml.a || die "dolib.a failed"
insinto /usr/include/bulletml
- doins *.h
+ doins *.h || die "doins .h failed"
insinto /usr/include/bulletml/tinyxml
- doins tinyxml/tinyxml.h
+ doins tinyxml/tinyxml.h || die "doins tinyxml.h failed"
insinto /usr/include/bulletml/ygg
- doins ygg/ygg.h
+ doins ygg/ygg.h || die "doins ygg.h failed"
dodoc ../README*
}