summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-30 13:19:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-30 13:19:42 +0000
commite33d9bc68005d0eeac958831c008c983880f0f2c (patch)
treed6db3b4549809c5b2779daaa39820f910ee0833b /dev-libs/libbsd
parentVersion bump. (diff)
downloadgentoo-2-e33d9bc68005d0eeac958831c008c983880f0f2c.tar.gz
gentoo-2-e33d9bc68005d0eeac958831c008c983880f0f2c.tar.bz2
gentoo-2-e33d9bc68005d0eeac958831c008c983880f0f2c.zip
Version bump; removing hard requirement for GNU .init_array section support, thus, making the package even more portable.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/ChangeLog8
-rw-r--r--dev-libs/libbsd/libbsd-0.7.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-libs/libbsd/ChangeLog b/dev-libs/libbsd/ChangeLog
index e2ef2526b40d..f248f057fce0 100644
--- a/dev-libs/libbsd/ChangeLog
+++ b/dev-libs/libbsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libbsd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.27 2014/07/20 13:36:08 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.28 2014/07/30 13:19:42 ssuominen Exp $
+
+*libbsd-0.7.0 (30 Jul 2014)
+
+ 30 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> +libbsd-0.7.0.ebuild:
+ Version bump; removing hard requirement for GNU .init_array section support,
+ thus, making the package even more portable.
20 Jul 2014; Tobias Klausmann <klausman@gentoo.org> libbsd-0.6.0.ebuild:
Stable on alpha, bug #510330
diff --git a/dev-libs/libbsd/libbsd-0.7.0.ebuild b/dev-libs/libbsd/libbsd-0.7.0.ebuild
new file mode 100644
index 000000000000..e7f8117f3b04
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/libbsd-0.7.0.ebuild,v 1.1 2014/07/30 13:19:42 ssuominen Exp $
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
+IUSE="static-libs"
+
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # http://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}