summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-06 09:19:27 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-06 09:19:27 +0000
commite997fa22b5b5e11c98cccb2b6af6bce1629ec402 (patch)
tree914c58653b471a80404fd35b097844d6d2a1e33c /dev-libs/libaio
parentBump to EAPI=3, add prefix keywords (diff)
downloadgentoo-2-e997fa22b5b5e11c98cccb2b6af6bce1629ec402.tar.gz
gentoo-2-e997fa22b5b5e11c98cccb2b6af6bce1629ec402.tar.bz2
gentoo-2-e997fa22b5b5e11c98cccb2b6af6bce1629ec402.zip
Bump to EAPI=3, add prefix keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libaio')
-rw-r--r--dev-libs/libaio/ChangeLog7
-rw-r--r--dev-libs/libaio/libaio-0.3.107.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/dev-libs/libaio/ChangeLog b/dev-libs/libaio/ChangeLog
index 197ac11e7fa5..4f357693295a 100644
--- a/dev-libs/libaio/ChangeLog
+++ b/dev-libs/libaio/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libaio
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/ChangeLog,v 1.49 2009/09/12 02:14:07 vostorga Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/ChangeLog,v 1.50 2010/04/06 09:19:27 abcd Exp $
+
+ 06 Apr 2010; Jonathan Callen <abcd@gentoo.org> libaio-0.3.107.ebuild:
+ Bump to EAPI=3, add prefix keywords
12 Sep 2009; Víctor Ostorga <vostorga@gentoo.org>
-files/libaio-0.3.15-2.5-2-Makefile.patch,
diff --git a/dev-libs/libaio/libaio-0.3.107.ebuild b/dev-libs/libaio/libaio-0.3.107.ebuild
index 207a2494ec16..574c54746435 100644
--- a/dev-libs/libaio/libaio-0.3.107.ebuild
+++ b/dev-libs/libaio/libaio-0.3.107.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.107.ebuild,v 1.12 2009/05/06 17:03:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.107.ebuild,v 1.13 2010/04/06 09:19:27 abcd Exp $
+
+EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -14,22 +16,21 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE=""
+
RESTRICT="test"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-sparc.patch
epatch "${FILESDIR}"/${P}-install-to-slash.patch
epatch "${FILESDIR}"/${PN}-0.3.107-ar-ranlib.patch
epatch "${FILESDIR}"/${PN}-0.3.106-build.patch
epatch "${FILESDIR}"/${PN}-0.3.107-generic-arch.patch
sed -i "/^libdir=/s:lib$:$(get_libdir):" src/Makefile Makefile
+ sed -i "/^prefix=/s:/usr:${EPREFIX}/usr:" src/Makefile Makefile
}
-src_compile() {
+src_configure() {
tc-export AR CC RANLIB
- emake || die "emake failed"
}
src_test() {
@@ -44,5 +45,5 @@ src_install() {
dodoc ChangeLog TODO
# remove stuff provided by man-pages now
- rm "${D}"usr/share/man/man3/aio_{cancel,error,fsync,read,return,suspend,write}.*
+ rm "${ED}"usr/share/man/man3/aio_{cancel,error,fsync,read,return,suspend,write}.*
}