summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-09-15 02:52:19 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-09-15 02:52:19 +0000
commit86a7f1937f7f8c0b10ac0c163ff4e078e1bc19ea (patch)
tree74b4c9349d53c16fd99d12cfba0f21eeefb8da71 /dev-libs/libaio
parentAdd libXft to dependencies (reported by Rob Lewis). (diff)
downloadgentoo-2-86a7f1937f7f8c0b10ac0c163ff4e078e1bc19ea.tar.gz
gentoo-2-86a7f1937f7f8c0b10ac0c163ff4e078e1bc19ea.tar.bz2
gentoo-2-86a7f1937f7f8c0b10ac0c163ff4e078e1bc19ea.zip
(non maintainer commit) add cross compiler support, thanks to Aaron Carroll in bug 197720
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-libs/libaio')
-rw-r--r--dev-libs/libaio/ChangeLog10
-rw-r--r--dev-libs/libaio/libaio-0.3.106-r2.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-libs/libaio/ChangeLog b/dev-libs/libaio/ChangeLog
index a224d0f8d966..89e88e1241a2 100644
--- a/dev-libs/libaio/ChangeLog
+++ b/dev-libs/libaio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libaio
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/ChangeLog,v 1.31 2007/01/06 02:57:25 kugelfang Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/ChangeLog,v 1.32 2008/09/15 02:52:19 darkside Exp $
+
+*libaio-0.3.106-r2 (15 Sep 2008)
+
+ 15 Sep 2008; Jeremy Olexa <darkside@gentoo.org> +libaio-0.3.106-r2.ebuild:
+ (non maintainer commit) add cross compiler support, thanks to Aaron Carroll
+ in bug 197720
06 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -libaio-0.3.15.ebuild,
-libaio-0.3.104.ebuild, -libaio-0.3.106.ebuild:
diff --git a/dev-libs/libaio/libaio-0.3.106-r2.ebuild b/dev-libs/libaio/libaio-0.3.106-r2.ebuild
new file mode 100644
index 000000000000..3ae0d08f40f9
--- /dev/null
+++ b/dev-libs/libaio/libaio-0.3.106-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.106-r2.ebuild,v 1.1 2008/09/15 02:52:19 darkside Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/andrea/libaio/ http://lse.sourceforge.net/io/aio.html"
+# Rip out of src rpm that Redhat uses:
+# http://download.fedora.redhat.com/pub/fedora/linux/core/development/source/SRPMS/
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~x86"
+IUSE=""
+
+DEPEND=""
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_test() {
+ cd "${S}"/harness
+ mkdir testdir
+ emake check prefix="${S}/src" libdir="${S}/src"
+}
+
+src_install() {
+ emake install prefix="${D}usr" libdir="${D}usr/$(get_libdir)" \
+ root="${D}" || die "emake install failed"
+ doman man/*
+ dodoc ChangeLog TODO
+
+ # remove stuff provided by man-pages now
+ rm "${D}"usr/share/man/man3/aio_{cancel,error,fsync,read,return,suspend,write}.*
+}