summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-31 22:00:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-31 22:00:19 +0000
commit49e94e097f733c0a1c459db8cd3aecfa17fa617a (patch)
tree95b7a754c5d2f5c4da121c173a610433eb46a497 /dev-libs/klibc
parenthppa stable, #198685 (diff)
downloadgentoo-2-49e94e097f733c0a1c459db8cd3aecfa17fa617a.tar.gz
gentoo-2-49e94e097f733c0a1c459db8cd3aecfa17fa617a.tar.bz2
gentoo-2-49e94e097f733c0a1c459db8cd3aecfa17fa617a.zip
Now with testing magic.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'dev-libs/klibc')
-rw-r--r--dev-libs/klibc/ChangeLog5
-rw-r--r--dev-libs/klibc/klibc-1.5.12-r1.ebuild30
2 files changed, 32 insertions, 3 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index 711c80e26517..44da86bdd3da 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.63 2008/10/31 21:32:22 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.64 2008/10/31 22:00:19 robbat2 Exp $
+
+ 31 Oct 2008; Robin H. Johnson <robbat2@gentoo.org> klibc-1.5.12-r1.ebuild:
+ Now with testing magic.
31 Oct 2008; Robin H. Johnson <robbat2@gentoo.org> klibc-1.5.12-r1.ebuild:
Bug #242454 - be sure to check both locations for kernel sources.
diff --git a/dev-libs/klibc/klibc-1.5.12-r1.ebuild b/dev-libs/klibc/klibc-1.5.12-r1.ebuild
index a7c193347603..cc5badd305a1 100644
--- a/dev-libs/klibc/klibc-1.5.12-r1.ebuild
+++ b/dev-libs/klibc/klibc-1.5.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.5.12-r1.ebuild,v 1.2 2008/10/31 21:32:22 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.5.12-r1.ebuild,v 1.3 2008/10/31 22:00:19 robbat2 Exp $
# Robin H. Johnson <robbat2@gentoo.org>, 12 Nov 2007:
# This still needs major work.
@@ -119,7 +119,7 @@ kernel_asm_arch() {
}
src_compile() {
- local myargs
+ local myargs="all"
local myARCH="${ARCH}" myABI="${ABI}"
# TODO: For cross-compiling
# You should set ARCH and ABI here
@@ -141,6 +141,7 @@ src_compile() {
cd "${S}"
use debug && myargs="${myargs} V=1"
+ has test $FEATURES && myargs="${myargs} test"
emake \
EXTRA_KLIBCAFLAGS="-Wa,--noexecstack" \
@@ -240,3 +241,28 @@ src_install() {
ln -snf asm-${KLIBCASMARCH} "${linkname}"
fi
}
+
+src_test() {
+ if ! tc-is-cross-compiler ; then
+ cd "${S}"/usr/klibc/tests
+ ALL_TESTS="$(ls *.c |sed 's,\.c$,,g')"
+ BROKEN_TESTS="idtest fcntl fnmatch testrand48"
+ failed=0
+ for t in $ALL_TESTS ; do
+ if has $t $BROKEN_TESTS ; then
+ echo "=== $t SKIP"
+ else
+ echo -n "=== $t "
+ ./$t </dev/null >/dev/null
+ rc=$?
+ if [ $rc -eq 0 ]; then
+ echo PASS
+ else
+ echo FAIL
+ failed=1
+ fi
+ fi
+ done
+ [ $failed -ne 0 ] && die "Some tests failed."
+ fi
+}