summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-21 15:53:05 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-21 15:53:05 +0000
commit4c0a4555bca02fe00ac8b1043652740f6303780b (patch)
treef221e073bd7e48a1837df07e3b344884ce9657f2 /dev-libs/jsoncpp
parentRemove old (diff)
downloadgentoo-2-4c0a4555bca02fe00ac8b1043652740f6303780b.tar.gz
gentoo-2-4c0a4555bca02fe00ac8b1043652740f6303780b.tar.bz2
gentoo-2-4c0a4555bca02fe00ac8b1043652740f6303780b.zip
Fix includedir path in pkg-config file, patch applied upstream. Remove old.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs/jsoncpp')
-rw-r--r--dev-libs/jsoncpp/ChangeLog11
-rw-r--r--dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch55
-rw-r--r--dev-libs/jsoncpp/jsoncpp-0.10.1.ebuild68
-rw-r--r--dev-libs/jsoncpp/jsoncpp-0.10.2-r1.ebuild (renamed from dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild)7
-rw-r--r--dev-libs/jsoncpp/jsoncpp-0.6.0_rc2.ebuild61
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.6.2-r1.ebuild (renamed from dev-libs/jsoncpp/jsoncpp-1.6.2.ebuild)7
6 files changed, 77 insertions, 132 deletions
diff --git a/dev-libs/jsoncpp/ChangeLog b/dev-libs/jsoncpp/ChangeLog
index 8ecc9b896b9e..74eef70dee95 100644
--- a/dev-libs/jsoncpp/ChangeLog
+++ b/dev-libs/jsoncpp/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/jsoncpp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/ChangeLog,v 1.19 2015/05/20 00:28:41 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/ChangeLog,v 1.20 2015/05/21 15:53:05 mgorny Exp $
+
+*jsoncpp-1.6.2-r1 (21 May 2015)
+*jsoncpp-0.10.2-r1 (21 May 2015)
+
+ 21 May 2015; Michał Górny <mgorny@gentoo.org>
+ +files/jsoncpp-1.6.2-fix-pkgconfig.patch, +jsoncpp-0.10.2-r1.ebuild,
+ +jsoncpp-1.6.2-r1.ebuild, -jsoncpp-0.10.1.ebuild, -jsoncpp-0.10.2.ebuild,
+ -jsoncpp-0.6.0_rc2.ebuild, -jsoncpp-1.6.2.ebuild:
+ Fix includedir path in pkg-config file, patch applied upstream. Remove old.
20 May 2015; Matt Turner <mattst88@gentoo.org> jsoncpp-0.10.2.ebuild,
jsoncpp-1.6.2.ebuild:
diff --git a/dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch b/dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch
new file mode 100644
index 000000000000..5c3420e45004
--- /dev/null
+++ b/dev-libs/jsoncpp/files/jsoncpp-1.6.2-fix-pkgconfig.patch
@@ -0,0 +1,55 @@
+From e6f1cffdd3fb04a0ed96319e6f8df6a7cbdd1557 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 19 May 2015 17:32:31 +0200
+Subject: [PATCH] Fix custom includedir & libdir substitution in pkg-config
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Do not prepend ${prefix} to substituted includedir & libdir
+in the pkg-config file -- if the paths are overriden by user, CMake puts
+absolute paths there (even if user specifies a relative path). Instead,
+use the absolute path provided by CMake and appropriately default
+LIBRARY_INSTALL_DIR & INCLUDE_INSTALL_DIR to absolute paths with
+${CMAKE_INSTALL_PREFIX} prepended.
+
+Fixes: https://github.com/open-source-parsers/jsoncpp/issues/279
+Signed-off-by: Michał Górny <mgorny@gentoo.org>
+---
+ CMakeLists.txt | 6 +++---
+ pkg-config/jsoncpp.pc.in | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 30038d5..d31a6ad 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,11 +25,11 @@ SET(LIB_SUFFIX "" CACHE STRING "Optional arch-dependent suffix for the library i
+
+ SET(RUNTIME_INSTALL_DIR bin
+ CACHE PATH "Install dir for executables and dlls")
+-SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX}
++SET(ARCHIVE_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}
+ CACHE PATH "Install dir for static libraries")
+-SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX}
++SET(LIBRARY_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}
+ CACHE PATH "Install dir for shared libraries")
+-SET(INCLUDE_INSTALL_DIR include
++SET(INCLUDE_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/include
+ CACHE PATH "Install dir for headers")
+ SET(PACKAGE_INSTALL_DIR lib${LIB_SUFFIX}/cmake
+ CACHE PATH "Install dir for cmake package config files")
+diff --git a/pkg-config/jsoncpp.pc.in b/pkg-config/jsoncpp.pc.in
+index 9613181..3ca4a84 100644
+--- a/pkg-config/jsoncpp.pc.in
++++ b/pkg-config/jsoncpp.pc.in
+@@ -1,7 +1,7 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/@LIBRARY_INSTALL_DIR@
+-includedir=${prefix}/@INCLUDE_INSTALL_DIR@
++libdir=@LIBRARY_INSTALL_DIR@
++includedir=@INCLUDE_INSTALL_DIR@
+
+ Name: jsoncpp
+ Description: A C++ library for interacting with JSON
diff --git a/dev-libs/jsoncpp/jsoncpp-0.10.1.ebuild b/dev-libs/jsoncpp/jsoncpp-0.10.1.ebuild
deleted file mode 100644
index 5e421ac4ac47..000000000000
--- a/dev-libs/jsoncpp/jsoncpp-0.10.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-0.10.1.ebuild,v 1.2 2015/04/13 19:22:49 vapier Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-any-r1
-
-DESCRIPTION="C++ JSON reader and writer"
-HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
-SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( public-domain MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~x86"
-IUSE="doc test"
-
-DEPEND="
- doc? (
- app-doc/doxygen
- ${PYTHON_DEPS}
- )
- test? (
- ${PYTHON_DEPS}
- )"
-RDEPEND=""
-
-pkg_setup() {
- if use doc || use test; then
- python-any-r1_pkg_setup
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DJSONCPP_WITH_TESTS=$(usex test)
- -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
- -DJSONCPP_WITH_CMAKE_PACKAGE=ON
-
- -DBUILD_SHARED_LIBS=ON
- # Follow Debian, Ubuntu, Arch convention for headers location
- # bug #452234
- -DINCLUDE_INSTALL_DIR="${EPREFIX}"/usr/include/jsoncpp
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- if use doc; then
- "${EPYTHON}" doxybuild.py --doxygen=/usr/bin/doxygen || die
- fi
-}
-
-src_test() {
- emake -C "${BUILD_DIR}" jsoncpp_check
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use doc; then
- dohtml dist/doxygen/jsoncpp*/*
- fi
-}
diff --git a/dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild b/dev-libs/jsoncpp/jsoncpp-0.10.2-r1.ebuild
index e022871380e2..2bb3707c2ae7 100644
--- a/dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild
+++ b/dev-libs/jsoncpp/jsoncpp-0.10.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild,v 1.3 2015/05/20 00:28:41 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-0.10.2-r1.ebuild,v 1.1 2015/05/21 15:53:05 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -26,6 +26,11 @@ DEPEND="
)"
RDEPEND=""
+PATCHES=(
+ # fix broken path subst in .pc file
+ "${FILESDIR}"/jsoncpp-1.6.2-fix-pkgconfig.patch
+)
+
pkg_setup() {
if use doc || use test; then
python-any-r1_pkg_setup
diff --git a/dev-libs/jsoncpp/jsoncpp-0.6.0_rc2.ebuild b/dev-libs/jsoncpp/jsoncpp-0.6.0_rc2.ebuild
deleted file mode 100644
index 1b92c69079b9..000000000000
--- a/dev-libs/jsoncpp/jsoncpp-0.6.0_rc2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-0.6.0_rc2.ebuild,v 1.3 2015/04/04 08:11:39 jer Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-any-r1
-
-MY_P="${PN}-src-${PV/_/-}"
-
-DESCRIPTION="C++ JSON reader and writer"
-HOMEPAGE="http://jsoncpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
-IUSE="doc"
-
-DEPEND="
- doc? (
- app-doc/doxygen
- ${PYTHON_DEPS}
- )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-cxx_wrapper() {
- set -- $(tc-getCXX) ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} "$@"
- echo "$@"
- "$@"
-}
-
-src_compile() {
- # This is the soname that other distros use.
- local soname="libjsoncpp.so.0"
-
- cxx_wrapper src/lib_json/*.cpp -Iinclude -shared -fPIC \
- -Wl,-soname,${soname} -o libjsoncpp.so.${PV%_*} || die
- ln -sf libjsoncpp.so.${PV%_*} ${soname} || die
- ln -sf ${soname} libjsoncpp.so || die
-}
-
-src_install() {
- # Follow Debian, Ubuntu, Arch convention for headers location, bug #452234 .
- insinto /usr/include/jsoncpp
- doins -r include/json
-
- dolib.so libjsoncpp.so*
-
- if use doc; then
- ${EPYTHON} doxybuild.py --doxygen=/usr/bin/doxygen || die
- dohtml dist/doxygen/jsoncpp*/*
- fi
-}
diff --git a/dev-libs/jsoncpp/jsoncpp-1.6.2.ebuild b/dev-libs/jsoncpp/jsoncpp-1.6.2-r1.ebuild
index a14b95d28c30..13a358c7fb59 100644
--- a/dev-libs/jsoncpp/jsoncpp-1.6.2.ebuild
+++ b/dev-libs/jsoncpp/jsoncpp-1.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-1.6.2.ebuild,v 1.2 2015/05/20 00:28:41 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-1.6.2-r1.ebuild,v 1.1 2015/05/21 15:53:05 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -26,6 +26,11 @@ DEPEND="
)"
RDEPEND=""
+PATCHES=(
+ # fix broken path subst in .pc file
+ "${FILESDIR}"/jsoncpp-1.6.2-fix-pkgconfig.patch
+)
+
pkg_setup() {
if use doc || use test; then
python-any-r1_pkg_setup