summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-11-24 10:56:48 +0000
committerMichał Górny <mgorny@gentoo.org>2013-11-24 10:56:48 +0000
commit51ba074e1aa7d1cd3aa3b67d23653f5a7a0605d6 (patch)
treebe0f5cce0302794e4df7c4e76ccc2b8e3971d73d /dev-libs/json-c
parentSupport in-source builds. (diff)
downloadgentoo-2-51ba074e1aa7d1cd3aa3b67d23653f5a7a0605d6.tar.gz
gentoo-2-51ba074e1aa7d1cd3aa3b67d23653f5a7a0605d6.tar.bz2
gentoo-2-51ba074e1aa7d1cd3aa3b67d23653f5a7a0605d6.zip
Enable multilib support, bug #488272.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs/json-c')
-rw-r--r--dev-libs/json-c/ChangeLog7
-rw-r--r--dev-libs/json-c/json-c-0.11-r1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/json-c/ChangeLog b/dev-libs/json-c/ChangeLog
index be55f24a944a..01e5e9111e5d 100644
--- a/dev-libs/json-c/ChangeLog
+++ b/dev-libs/json-c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/json-c
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-c/ChangeLog,v 1.29 2013/05/09 05:15:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-c/ChangeLog,v 1.30 2013/11/24 10:56:48 mgorny Exp $
+
+*json-c-0.11-r1 (24 Nov 2013)
+
+ 24 Nov 2013; Michał Górny <mgorny@gentoo.org> +json-c-0.11-r1.ebuild:
+ Enable multilib support, bug #488272.
09 May 2013; Mike Frysinger <vapier@gentoo.org> json-c-0.10-r1.ebuild,
json-c-0.11.ebuild, json-c-0.9-r1.ebuild:
diff --git a/dev-libs/json-c/json-c-0.11-r1.ebuild b/dev-libs/json-c/json-c-0.11-r1.ebuild
new file mode 100644
index 000000000000..d43c0cea5ae0
--- /dev/null
+++ b/dev-libs/json-c/json-c-0.11-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-c/json-c-0.11-r1.ebuild,v 1.1 2013/11/24 10:56:48 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-multilib
+
+DESCRIPTION="A JSON implementation in C"
+HOMEPAGE="https://github.com/json-c/json-c/wiki"
+SRC_URI="https://s3.amazonaws.com/json-c_releases/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc static-libs"
+
+# tests break otherwise
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed -i -e "s:-Werror::" Makefile.am.inc || die
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ # Disable old lib compatibility
+ myeconfargs=(--disable-oldname-compat)
+ autotools-multilib_src_configure
+}
+
+src_test() {
+ export USE_VALGRIND=0 VERBOSE=1
+ autotools-multilib_src_test
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${S}"/doc/html )
+ autotools-multilib_src_install
+
+ # add symlink for projects not using pkgconfig
+ dosym ../json-c /usr/include/json-c/json
+}